When I switch on my Laptop and chose Ubuntu to start it up. I am stuck with console only asking me for my username then for my password.

I do not know what had happened to my Ubuntu, last thing I remember is using Ubuntu Tweak, Bleach, Bleach(root).

After that I could not start an log in to the GDM.

  • Sounds like it might be a graphics driver problem - I've seen that. But here's something you might try before that: sudo start lightdm – Chuck R Nov 15 '12 at 0:07
  • If that doesn't work you probably need to reinstall your graphics card driver. Note: if you have an ATI graphics card and use the legacy proprietary binary from amd.com then you will run into issues installing the legacy driver on 12.10 due to kernel header changes. My advice there: sudo apt-add-repository ppa:makson-96/fglrx && sudo apt-get update && sudo apt-get install fglrx-legacy – Chuck R Nov 15 '12 at 0:11
  • my graphics driver is nVIDIA – malhobayyeb Nov 15 '12 at 0:11
  • How can I connect to Internet in console? – malhobayyeb Nov 15 '12 at 0:15
  • 1
    Got ya. The easiest way is using a wired connection, but I'm assuming you don't have that luxury (laptop). Give me a few minutes and I'll guide you on how to connect via wifi from the console (it's been a while). – Chuck R Nov 15 '12 at 0:27

This is not related to graphics drivers.

I have installed ia32 package with lots of dependencies. Then I remove it and I have done autoremove, too.

I figured out that gnome-shell, gdm ...etc were removed, too. So, because they where my main interface, I couldn't log in to my Ubuntu.

I have connected to internet using the network cable and installed gnome-shell

  • This happened to me after installing all gnome development dependencies (via "jhbuild sysdeps --install"). A combination of removing these packages then installing gdm brought my login screen back. I also had to chown ~/.Xauthority before graphical login would succeed. I learnt my lesson; now I have gnome dev packages in a VM. – Nathan Jan 20 '14 at 20:13

April 2013, I had the same issue, Ubuntu 12.04 LTS, also after using Ubuntu Tweak.

Here's how I fixed it :

It's almost the same as Githlar's first post.

My video card is AMD ATI Radeon HD and I used wired internet.

(1) I chose to start the login console ;
(2) then tried to reinstall video drivers : sudo apt-get update && sudo apt-get install fglrx and of course, returned "yes" to install the packages to install.

This installed 3 packages : dkms, fglrx and fglrx-amdccle. An error has occured while installing dkms but it hasn't interrupted the installation.

The problem's fixed, but still have that resolution issue with lightdm login screen (unsupported by the monitor).

Hope it may help people with similar issues.

  • This is not an answer. It seems you've different than this question. So, you can ask your question separately as new question. – tuxtu Apr 19 '13 at 1:26

This is a common problem that I've seen with computers using the proprietary nVidia driver. This happens every time there's a kernel update.

Make sure you have linux-headers-generic installed: sudo apt-get install linux-headers-generic

If you've installed the drivers before and still have the last installer:

  1. Make sure you are in VT1 (Ctrl+Alt+F1)
  2. sudo stop lightdm to kill X
  3. The installer is probably located in ~/Downloads: cd ~/Downloads
  4. sudo ./NV*run to start the nVidia installer
  5. Let it install and reboot, you should be back to a graphical desktop

If you don't have the drivers already downloaded, install Lynx (a console web browser) sudo apt-get install lynx and navigate to http://www.nvidia.com/object/unix.html to download the correct drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.