3

I have tried to completely remove apache2.2 from my system. But the only thing that happens is that apt-get will remove "apache2-mpm-prefork" and install "apache2-mpm-worker".

I have killed all apache processes and tried in both Synaptic. and apt-get from terminal. Why won't my system delete apache, and why will it install "apache2-mpm-worker"?

  • 1
    What exactly have you tried and what's the terminal output of such a failing try? – htorque Jan 15 '11 at 18:53
  • fluteflute below here was right. I didn't try to uninstall the whole package, only these "virtual packges". My problem is solved with my newfound knowlege! – TheLugal Jan 15 '11 at 20:48
5

Short answer: you need to purge the apache2 package as well as apache2.2-bin and apache2.2-common.

Explanation: this package is a "virtual package" - if you have it installed the system will make sure that one of apache2-mpm-event, apache2-mpm-itk or apache2-mpm-prefork or apache2-mpm-worker is installed. Note that these four packages themselves each depend apache2.2-bin and apache2.2-common.

  • 1
    You can also, usually for a sanity check, use a wildcard like "sudo apt-get remove apache2* " to see what relevant installed packages match. I often run this with the -s (simulate) just for safety. Another way to find installed packages would be something like " dpkg --list | grep apache " – belacqua Jan 15 '11 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.