After upgrading to 12.10 from 12.04 none of my virtualbox virtual machines can use NAT to access the network. I have tried vboxmanage modifyvm --natdnsproxy1 on and/or --natdnshostresolver1 on, but still doesn't work. What can I do to resolve this? I have also upgraded to Virtualbox 4.2.4 to attempt to resolve this issue.


I had the same problem, but without updating to 12.10: I already was in 12.10 last Wednesday, the last time I used the virtualmachine, but on Sunday I couldn't access the network from any virtual OS (tried both Windows 7 and Windows 8). Also tried to update from virtualbox 4.1 (bundled with ubuntu) with virtualbox 4.2 from the Oracle website, but nothing changed.

I guess an Ubuntu update broke something.

I've tried an answer from another thread and it does work

VBoxManage modifyvm "name" --natdnshostresolver1 on
VBoxManage modifyvm "name" --natdnsproxy1 on

(PS: I couldn't add this as a comment to the original question, don't have enough reputation, but thought it could be useful)

| improve this answer | |

One of the reasons it does not work directly from 12.10 is here https://www.virtualbox.org/ticket/10864

VirtualBoxes uses hosts /etc/resolv.conf file to map dns into its internal dhcp, thus blocking name resolution. In the waiting for a fix I had to manually setup dns servers on hosts resolv.conf file

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.