I manually downloaded ia32-libs-multiarch from packages.ubuntu.com and the version should be compatible with the 64bit 12.10.

From terminal, I get a 'package has no installation candidate. After several manual attempts with dpkg, I tried manually installing ia32-libs from HERE, but failed.

What is the correct way to install ia32-libs?


I had same issue, just posting my findings to help anyone else.

I ran

sudo apt-get install gcc-4.7-multilib 

And it installed the ia32-libs from here I assume, suddenly works. I needed it to run XAMPP on Ubuntu 12.10 - May help someone!

  • 2
    Installing gcc-4.6-multilib works on 12.04 (which has no gcc-4.7-multilib package. – Peter Gluck Feb 28 '13 at 7:03

First of all, did you try installing Skype before installing the libs? I've seen a few reports that there's no need to manually install ia32-libs on Quantal (ie - 32bit applications install just fine), though I haven't confirmed that myself. If you haven't, try that first. If you have, then continue on (and, since you're new, it'd be good to read on, anyway).

You don't need to download packages from packages.ubuntu.com in order to install them. That site is really only there for documentation and reference purposes.

All you need to do is open up terminal and run:

sudo apt-get install ia32-libs

It'll prompt you for your password. Put it in, and let it do its thing. Once it's done, you should be able to install Skype without issue.

  • I obviously tried that before posting here. Can you please answer my question? How do you install something that has .postinst extension? – flavian Nov 13 '12 at 20:56
  • 1
    I did answer your question, read the rest of my answer. The .postinst extension is not an installable file, it's the extension for the post install script, which is designed to be run after an installation. If you're trying to run the .postinst file, then you're using the wrong file to begin with. – Shauna Nov 13 '12 at 22:00

download one of these site, and install manually by dpkg. Managed to solve now because apne gave the electric light in my house at the time that this updating ubuntu and did not end because case. But after this action already solved.

enter link description here


protected by Community Dec 23 '13 at 11:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.