I made a fresh install to Ubuntu 12.10 a while ago and tried to install the fglrx via software-properties-gtk. But when I install and restart one of the new versions, I can't acces unity (only desktop is there, no launcher or dash or window frames), and gnome3 only in fallback mode (automatically). Also the graphics doesn't seem to be fast, e.g. when I'm scrolling in software center. (I want to use gnome3.) So I don't think the drivers actually 'work'.

The drivers worked on 12.04. But I want to avoid a downgrade, since the newest gnome3 version only seems to be in the 12.10 repositorys. I have no idea about what is wrong. Any ideas? Or anything I have to take care of with the new driver selection in software-properties-gtk?

My graphics card: Radeon HD 6870 --- OS: Ubuntu 12.10

When I try to install the (stable) driver from the amd website, the following error message occures in it's log file:

Supported adapter detected. Check if system has the tools required for installation. fglrx installation requires that the system have kernel headers. /lib/modules/3.5.0-18-generic/build/include/linux/version.h cannot be found on this system. One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver. Optionally, run the installer with --force option to install without the tools. Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.


You should install the package linux-headers-generic with this command:

sudo apt-get install linux-headers-generic

or use this link:

Install via the software center

Then reinstall the video driver.

| improve this answer | |
  • 1
    The answer from Daniel Zippert is correct and helpful, but if anyone has the same problem, use this answer from Hernan, since this way the kernel headers are also updated if the kernel gets updates. This way you won't run into the same problem later on (I did). – verpfeilt Jan 31 '13 at 23:21

If your kernel version is 3.5.0-18 the string is:

sudo apt-get install linux-headers-3.5.0-18-generic
| improve this answer | |
  • I did this and tried the drivers in the repository first, and it works! Great thanks! Although I'm a bit disappointed because software-properties-gtk didn't do this itself. Also I'd never have figured this out (the error about the header files) when I wouldn't have tried the driver from amd's website. – verpfeilt Nov 14 '12 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.