The help browser of Wolfram Mathematica is not getting window focus when clicked on it. Clicking links or buttons in the help browser works without the window focus, but copying code from or typing in it doesn't. I can get window focus on the help browser by using the alt+tab or the Window menu though. Switching focus between notebooks behaves normally.

I'm running Mathematica on Ubuntu 12.10. Mathematica is the only software that has this behavior.

Has anyone else experienced this behavior or know a solution to it?

P.S. Question posted on mathematica.stackexchange.com too.

  • Perhaps you should upgrade to 13.04 first... May 12, 2013 at 18:27
  • At the time of my question 13.04 wasn't released yet... But I can report now that 13.04 behaves similarly. May 13, 2013 at 9:15
  • Try upgrading to mathematica 9. May 14, 2013 at 1:59
  • 1
    At the time of my question mma9 wasn't released yet... But I can report now that mma9 (even 9.0.1) behaves similarly. May 14, 2013 at 10:01
  • 2
    @haneefmubarak: your two errors could have been prevented by just looking at the date at which i posted the question. Once bitten, twice shy... May 14, 2013 at 10:04

1 Answer 1


The problem likely lays in one of two places

Suggested resolution not ordered by importance

  1. The window manager (compiz)
  2. The Java runtime

The window manager could just be giving you a hard time, they're easy to replace.

Ubuntu is not installing the Oracle Java by default anymore due to licensing issues. It's conceivable that the opensource version has a Java bug resulting in this window focus issue. Determine which version of Oracle Java you need ( don't install v7 unless necessary) and retry. Since Oracle Java is unsupported, I don't wish to cite other installation references as I don't know how well they work or even if they're secure.

Finally, Wolfram support is awesome, if you've paid for MM you should be able to get a response in a day or two. I remember being in their beta program for MM 4.0, they forgot to statically link motif to the build and the only reason it worked on my system ( well sorta worked) was because I had lesstif installed. They turned around the fix in about 2 days.

Not the answer you're looking for? Browse other questions tagged or ask your own question.