My brand new system is randomly freezing and I don't know how to debug the issue.


  • AMD A10-5800k
  • Asus F2A85-M motherboard
  • Integrated Radeon HD 7660D
  • 8gb Samsung ddr3 1600
  • Ubuntu 12.10
  • Gnome shell / Unity (issue exists in both)

xorg.conf (relevant parts):

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:0:1:0"
    Option      "TexturedVideoSync" "on"
    Option      "UseFastTLS" "2"

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "Monitor0"
    DefaultDepth     24
    Option      "UseEDID" "False"
    Option      "ExactModeTimingsDVI" "True"
    Option      "NoBandWidthTest" "true"
    Option      "ModeValidation" "AllowNon60hzmodesDFPModes, NoEDIDDFPMaxSizeCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoDFPNativeResolutionCheck, NoMaxSizeCheck, NoMaxPClkCheck, NoEDIDModes"
    Option      "UseEDIDDPI" "False"
    Option      "UseEDIDFreqs" "0"
    Option      "NoLogo" "True"
    Option      "Coolbits" "1"
    Option      "metamodes" "DFP-0: 2560x1440_60 +0+0"
    SubSection "Display"
        Depth     24
        Modes    "2560x1440"
  • I ran memtest on my ram and it checks out fine.
  • I have tried using the latest fglrx and fglrx-beta.
  • I have loaded 3.6.x kernel.
  • I do not see anything relevant in dmesg, kern.log, syslog, .xsession-errors or Xorg.log.
  • I cannot ssh into the machine when frozen from another machine.
  • I know that system resources not being stressed when the crashes happen.
  • It seems that video and any gaming (very simple graphics games) contribute to the freezes most frequently. However, I have experienced the crash before when just using Chrome.
  • I suspect the crashes are xorg/fglrx related, but I have no evidence to back that up.

Where should I look? What should I grep for? What should I try next?

  • poss dupe askubuntu.com/questions/4408/… – Ringtail Nov 13 '12 at 5:35
  • Not a dupe. Maybe I should be more specific about fglrx in the question. – racerror Nov 13 '12 at 16:33
  • Per an offline suggestion, I tested my machine using an nvidia video card and the same issue persisted. My question is incorrect, it was not an fglrx issue. It appears to be a Chrome + Flash issue, completely freezing my machine. Using Firefox with flash-plugin and I have not experienced any issues. – racerror Nov 25 '12 at 2:39
  • 2
    Which GPU flags are toggled under chrome://flags? Try disabling "GPU compositing" and and enable "Disable GPU VSync". – madmaze Dec 17 '12 at 20:15
  • From my experience with Nvidia card, this can be is an overheating issue with the GPU. Try install fan control for your GPU, either with dynamic setting or keep it high for testing purpose. – John Siu Dec 28 '12 at 19:01

This has worked for me. I think that there may be a header issue with AMD and Nvidia graphics cards.

sudo apt-get purge fglrx
sudo apt-get install linux-headers-generic

Reboot and then Install proprietary drivers via Software Sources.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.