Online it says I should be able to find pdfedit in the software center. That doesn't work for me. I've tried many times. Is there any other way to install pdfedit or master pdf edit on ubuntu 12.10.


As mentioned above, Qt3 is still supported in 12.04 LTS. However both Qt4 and Qt3 are capable of coexisting together on the same machine, therefore I suggest reloading the Qt3 libraries from the archive instead of trying to convert pdfedit to use qt4 libraries.

I've tested the following commands on 12.10, and they work as of this post. If not, you might need to check the archive as see if the version name/link has changed...

On 32 bit systems use this:

Install Qt3 library (libqt3-mt) from 12.04 LTS:

FILE=`mktemp`; wget http://us.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-mt_3.3.8-b-8ubuntu3_i386.deb -qO $FILE && sudo dpkg -i $FILE; rm $FILE

Install pdfedit:

FILE=`mktemp`; wget http://us.archive.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_0.4.5-2_i386.deb -qO $FILE && sudo dpkg -i $FILE; rm $FILE

For 64 bit versions use the following commands:

Install Qt3 library (libqt3-mt) from 12.04 LTS:

FILE=`mktemp`; wget http://us.archive.ubuntu.com/ubuntu/pool/main/q/qt-x11-free/libqt3-mt_3.3.8-b-8ubuntu3_amd64.deb -qO $FILE && sudo dpkg -i $FILE; rm $FILE

Install pdfedit:

FILE=`mktemp`; wget http://us.archive.ubuntu.com/ubuntu/pool/universe/p/pdfedit/pdfedit_0.4.5-2_amd64.deb -qO $FILE && sudo dpkg -i $FILE; rm $FILE

pdfedit is not available in Ubuntu 12.10 Quantal. You can find the distributions covered on Launchpad.

Sadly it still relies on Qt3, which has been taken out of Ubuntu with 12.10 Quantal, where only Qt4 remains.

As backwards compatibility is not offered between major versions of Qt, it was removed from the archives.


As mentioned, PDF Editor will not work in 12.10, because of the dependency on QT3. However, QT3 is included in 12.04 LTS. I know this isn't a great solution, but since LTS is -- well -- long-term, you could always keep a 12.04 running in a virtual box until needed.

To the other part of your question, I've looked too and can't find anything else that actually works in terms of editing PDF content, and not just shuffling/adding/deleting pages.


You can download the source code from SourceForge or find old packages online, but the installation or buildconfigure cannot continue due to a dependency on Qt3.

One would have to port it to Qt4. Since this this tool is not one of many, I don't understand why it still relies on Qt3.

Meanwhile I am looking for alternatives. No luck.


I can confirm that jsncttn's solution works, I tried it too. One caveat is the first time I ran the first command, it could not install libqt3-mt but this failed because of missing dependencies:

libxcursor1:i386 (1:1.1.13-1), libxfixes3:i386 (1:5.0-4ubuntu5), libxft2:i386 (2.3.1-1), libxinerama1:i386 (2:1.1.2-1), libxrandr2:i386 (2:1.4.0-1)

I made a note of them and launched Synaptic Package Manager to see if they were there and install them, and since somehow they were detected as "broken packages" by Synaptic I selected to fix the broken packages, reran the first command to install libqt3-mt, then the second command to install PDFEdit, and it installed fine. When Ubuntu 12.04 was released libqt3-mt was still in Debian Testing (Wheezy), but was removed from Debian Testing in late May 2012, so my best guess it that's why it got dropped from Ubuntu 12.10. Oddly enough is in Debian sid so maybe it will get into Ubuntu.

qt3 removed from Debian May 2012: http://www.debian.org/News/weekly/2012/11/#qt3

A project to backport qt3 back to Debian Wheezy/Sid: http://projects.tryphon.eu/blog/2012/10/12/qt3-backport-for-debian-wheezy-and-sid/

Currently since libqt3-mt is (back?) in sid .... I don't know if that means it might make it to be included in Ubuntu 13.04 (Raring).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.