I have ubuntu 12.04, on a Dell Inspiron 14r, Intel HD 3000. I set on the Power settings, "When the lid is closed: Do nothing." The password prompt worked just fine when i closed and opened the lid.

But now after i have updated the Intel graphics driver, most of the times, when i open the laptop lid, there's no password prompt. I've tried typing the password blindly, but it does not respond to keyboard or mouse input.

The only way out of it, is to use tty1, log and restart lightdm with the following command:

sudo service lightdm restart

But the problem is, it closes all my previous opened programs.

closed as too localized by Jorge Castro, gertvdijk, Ringtail, Luis Alvarado, Eric Carvalho Jan 9 '13 at 1:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I experienced this problem sometimes (not every time I used to close the lid). Since I upgraded to 12.10 it has not happened anymore. – jasmines Nov 23 '12 at 9:25

Try updating the intel driver module again in case it's been fixed. It might be a regression back to the resume bug from earlier this year: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/966744.

In the meantime, I suggest you turn the lock screen feature off. Open 'system settings' and click 'brighness and lock' and toggle the lock to OFF

You will still be able to CtrlLock the screen manually, it just won't automatically lock when you close the lid.

  • How do i update the intel drivers? I already turn off the auto lock screen. In case updating the drivers don't work, how do i go back to the "default" intel drivers that came with ubuntu 12.04? – ThiagoPonte Nov 26 '12 at 11:25
  • Thanks for the tips. I have updated the drivers using this PPA: sudo add-apt-repository ppa:xorg-edgers/ppa Now my problem is gone. – ThiagoPonte Nov 27 '12 at 17:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.