I am using Ubuntu 12.04. When I try to take a screenshot with the default screenshot utility or Shutter a dialog box appears saying that /home/user/Pictures is a read-only file system.

I checked the permission of the folder but it was set to the default value: creating and deleting files. What might have gone wrong here? How can I solve this?

This I didn't have this problem before, not even yesterday. And as far as I remember, I didn't install any software that might have changed the permissions.

  • 1
    What is your folder's owner and group on the file permissions? – Hckr Nov 12 '12 at 14:04
  • The owner of that folder is me, that is minhaz, the permission is drwxr-xr-x – Ratul Nov 12 '12 at 15:18
  • I can take screenshots again :/ No errors or whatsoever! I wonder what was the problem, and how it got solved. I just shut off my PC for a while, and now it's gone! – Ratul Nov 12 '12 at 15:27

can you manually make a file in Pictures? One command to do so is this:

touch ~/Pictures/test.fyle
  • Yes, I can do so from terminal. Only the sceenshot applications seem to have the permission problem. I can even save images in that folder with Gimp! – Ratul Nov 12 '12 at 15:10
  • Thanks for looking in to my problem @psny :) The problem is solved. When you asked if I can manually make files, I tried that with terminal as well as with Gimp. Then Tried out Shutter again, and it worked! – Ratul Nov 12 '12 at 15:29
  • you're welcome. I'm not sure what happened, though. – philshem Nov 13 '12 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.