I would like to remove modem-manager service from my boot, how can I do it ?

  • Found this question after getting intermittent "SAM-BA operation failed" error using Arduino IDE to flash an Adafruit Feather M0- see digistump.com/board/index.php/… . Executing systemctl status ModemManager.service shows that modem-manager is the culprit: Could not grab port (tty/ttyACM0): 'Cannot add port 'tty/ttyACM0', unhandled serial type' Mar 18, 2017 at 23:06

5 Answers 5

systemctl disable ModemManager.service
systemctl stop ModemManager.service

This worked to disable UML-295 modem from being managed by ModemManger which in turn enabled web-control via http://mbb.vzw.com on CentOS 7.

Check after disabling via:

systemctl list-dependencies multi-user.target | grep Modem
  • working for Ubuntu 16.04. Deactivates for me most of my "SetLineState" on my USB-Trace.
    – Cutton Eye
    Mar 7, 2018 at 13:22
  • 3
    Short Answer: sudo systemctl disable ModemManager Mar 14, 2019 at 22:06

The simplest way is to:

sudo apt-get purge modemmanager

Works fine in 12.04 LTS. Nothing in my system had dependencies on modemmanager.

Or you could search for "modemmanager" in the Ubuntu Software Center and remove it from there (the title is "D-Bus service for managing modems").

  • you are right but does you need it for connection with mobile phone ? May 25, 2013 at 19:51
  • 1
    @Postadelmaga: Well, I guess it depends how your software connects to your phone. If you find you do need it after all, you can always re-install it with sudo apt-get install modemmanager, no?
    – mivk
    May 27, 2013 at 17:39
  • 3
    you are right, but what happen if I have no internet connection in that moment ( and y should I use my phone to navigate if I have internet :) What I'm looking for is a way to not load it every boot, but still be able to run it if I need it .... May 28, 2013 at 10:22

This it looks to work fine:

sudo mv /usr/share/dbus-1/system-services/org.freedesktop.ModemManager.service /usr/share/dbus-1/system-services/org.freedesktop.ModemManager.service.disabled

Instead this doesn't work ( don't know y ):

"echo manual | sudo tee -a /etc/init/modemmanager.override"
  • 2
    As of ubuntu 14.04 and Linux Mint 17.3, it is ModemManager1; I'm now used to do also sudo ugo-x /usr/sbin/ModemManager.
    – metadings
    Jun 12, 2016 at 20:32
  1. If it is SysV init style symbolic links

    update-rc.d [-n] [-f] base_name remove
  2. If it is per user (X11 session), check the following folders and remote corresponding files:

  • thank u but it is not a SysV init ... it is a upstart service, see my answer below Nov 14, 2012 at 4:17

I found this had only a deleterious function when I tried the experimental version in Debian Sid and it failed to find my modem at all. That nearly doubled my speed and drops and failures became rare. I will probably remove it but for the time I want it to suspend function.

In /etc/init.d I stored this file:

# The ModemManager appears to slow down and interfere with the internet on my Dell laptop.
ModemManager --no-auto-scan

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .