When I try to run Metacity in Ubuntu2D(12.04), I get the following message:

alisa@ubuntu:~$ metacity 
Window manager warning: Screen 0 on display ":2.0" already has a window manager; 
try using the --replace option to replace the current window manager.

I get the same message when running Compiz from the command line in 3D (it opens fine through the GUI). I understand that these should be the default managers for the respective sessions.

I'm trying to create a custom Gnome session using the following instructions: unity launcher-free session. Here is what I've put into my .session file (note the reference to Metacity):

[GNOME Session]
Name=Custom Unity2D Session

I can't launch the custom session (it does show up on my login screen). I think Metacity might be the problem, since it's not recognized as the default. Please let me know if you think there may be other issues affecting my custom session. I am new to Linux, so list anything you think might be helpful. Thank you!

Update: Metacity seems to be the default...

alisa@ubuntu:~$ tail /usr/share/gnome-session/sessions/gnome-fallback.session
[GNOME Session]
Name=GNOME fallback (Safe Mode)

alisa@ubuntu:~$ tail /usr/share/gnome-session/sessions/ubuntu-2d.session
[GNOME Session]
Name=Ubuntu 2D

So why the terminal "window manager warning" message?

  • I tried specifying Metacity as my default manager by adding exec metacity to the .xinitrc file, and I tried running metacity --replace, but neither worked. – QuietThud Nov 12 '12 at 22:21
  • AWN behaves the same way as Compiz: it can be launched from GUI but not from terminal. I can't launch Metacity at all but I can find the associated files using 'locate'. – QuietThud Nov 12 '12 at 22:24
  • Update #2: I changed the permissions for Metacity through sudo nautilus to enable it to be run as an executable (since Compiz and AWN run fine from GUI but not from terminal), and got the same warning message as above. =( – QuietThud Nov 13 '12 at 2:48
  • Metacity is the default window manager for Unity2d, you don't need to run it from within the session, because it autostarts. – mikewhatever Nov 14 '12 at 7:19
  • Yeah, I have since noticed it in my open processes--but I'm pretty sure it's supposed to have a GUI, which I haven't managed to open. – QuietThud Nov 14 '12 at 7:35

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.