I have google Chrome 8.0.552.237 on Ubuntu 10.10 64-bit and flash is not working, I have tried a variety of methods to install flash, including Firefox flash-aid and the flash-installer package and nothing is working for me. I have even uninstalled and reinstalled chrome to no avail.

I get "missing plugin" message where flash plugin should be in a website.

What am I missing?

I have a variety of plugins returned by jgbelacqua's command:


I'm not sure which is necessary and which not.

I should note tho that my Chromium does have flash and it does work... just not chrome or firefox.

  • 1
    Have you tried this? askubuntu.com/questions/2544/where-is-the-flash-in-chrome Jan 14, 2011 at 20:51
  • 1
    Yes Jorge but no luck there either.
    – Jim Ford
    Jan 14, 2011 at 21:10
  • I removed the files on the list and uninstalled everything flash related from software center, then tried the sevenmachines repo 64bit and got same list back.
    – Jim Ford
    Jan 18, 2011 at 17:03
  • Can you give us the output of cat /proc/cpuinfo | grep flags?
    – user77111
    Jul 16, 2012 at 18:37
  • Cumulus007: sadly no as this question was answered > 1.5 years ago and I no longer have that computer.
    – Jim Ford
    Aug 1, 2012 at 13:58

5 Answers 5


ok Crossover linux added a second flash plugin through wine for chromium / chrome, to turn off the second plugin do the following:

   1. load chrome
   2. hit the wrench button
   3. select preferences
   4. go to Under the Hood tab
   5. under Privacy section hit Content Settings button
   6. select Features -> Plug-ins
   7. push Disable individual plug-ins
   8. In the upper right hit the + next to Details
   9. Scroll down until you see Shockwave Flash
  10. disable all entries other than /usr/lib/mozilla/plugins/libflashplayer.so 
     (or the specific flash version you installed).

Reference Source: http://www.google.com/support/chrome/bin/answer.py?hl=en&answer=108086

A second option would be to uninstall flash from your crossover bottles. For me this fixed flash in Firefox as well.


Try the beta version (9.0). I'm using Kubuntu 10.10 64bits, and Flash works perfectly.

You can get this version from the the chromium-daily PPA:

sudo apt-add-repository ppa:chromium-daily/beta
sudo apt-get update && apt-get upgrade

Note: if you've previously installed the chromium-browser-l10n package for a multi-language browser, you have to uninstall it. This package is not included with the beta package, so you're stuck with an English interface.


Purge (completely remove) and reinstall flashplugin-nonfree with sudo apt-get purge flashplugin-nonfree followed by sudo apt-get install flashplugin-free . This downloads a new version of Flash player complete with new updates, etc. automatically. No reboot needed.

  • helpful answer for the general problem "flash isn't working" but not for the specific case with crossover
    – Jim Ford
    Aug 1, 2012 at 14:00

It installs Flash for FF. Restart Chrome and it works.... I read about these kind of solutions before. When you cannot install in Chrome try installing in FF..... With thanks to Wizard1000


After fighting flash problems on a couple of different Ubuntu installs, I came across a pointer to a FireFox add-in called Flash-Aid. It is specific to Ubuntu, and it works to try to find the best Flash plugin for your setup. Even though I prefer to run Chrome instead of FireFox, this little tool was able to solve my problems.

  • if you will read the question, it notes that flash-aid did not help in my situation, although good to know in other situations I suppose.
    – Jim Ford
    Jul 12, 2011 at 11:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .