2

So I was doing fine then i upgraded my system to 12.10 and now i cant get my system to update all of its packages properly. no matter what i do, what is happening here and how do i fix this. if i would have thought 12.10 would be this much of a hassle i would have never upgraded..... here is a sampling of the code that returns from "apt-get -f install" It should also be noted that it is just these 6 packages only. no other packages have given me this kind of trouble. well i should say as of now. It was just 5, but them i got an update for unity, and now unity-common is added to the trouble makers. which prevents me from further upgrading the actual unity package as this package is a dependancy.

Preparing to replace usb-modeswitch-data 20120120-0ubuntu1 (using .../usb-modeswitch-data_20120815-1_all.deb) ...

/var/lib/dpkg/info/usb-modeswitch-data.prerm: 4: /var/lib/dpkg/info/usb-modeswitch-data.prerm: dpkg-maintscript-helper: Input/output error

dpkg: warning: subprocess old pre-removal script returned error exit status 2

dpkg: trying script from the new package instead ...

/var/lib/dpkg/tmp.ci/prerm: 4: /var/lib/dpkg/tmp.ci/prerm: dpkg-maintscript-helper: Input/output error

dpkg: error processing /var/cache/apt/archives/usb-modeswitch-data_20120815-1_all.deb (--unpack):

subprocess new pre-removal script returned error exit status 2

/var/lib/dpkg/info/usb-modeswitch-data.postinst: 7: /var/lib/dpkg/info/usb-modeswitch-data.postinst: dpkg-maintscript-helper: Input/output error

dpkg: error while cleaning up:

subprocess installed post-installation script returned error exit status 2

Errors were encountered while processing:

/var/cache/apt/archives/network-manager_0.9.6.0-0ubuntu7_i386.deb

/var/cache/apt/archives/pcmciautils_018-8_i386.deb

/var/cache/apt/archives/unity-common_6.10.0-0ubuntu2_all.deb

/var/cache/apt/archives/whoopsie_0.2.7_i386.deb

/var/cache/apt/archives/usb-modeswitch_1.2.3+repack0-1ubuntu3_i386.deb

/var/cache/apt/archives/usb-modeswitch-data_20120815-1_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

I would also like to note i have cleaned apt cashe both through the terminal and manualy, i have tried installing them manually through dpkg from both the /var/cache/apt/archives/ location and from my own manually downloaded .deb files. i have tried using dpkg-reconfigure and i have used bleachbit to clean my system. I have also tested both my HDD and memory and found no significant errors to lead to the input/output errors. Quite frankly i am just out of options and have grown tired of trying to google a solution to this mess but still do not wish to pursue backing up settings and reinstalling the system. Any help would be appreciated.

I am only interested in answers, please leave your feeling towards grammar, punctuation, and bias towards how a "post should look" at the door. If you dont have something to contribute towards solving my problem then you are just doing nothing but contributing to it. Thank you.

1 Answer 1

0

Try disabling any PPA's or other non-standard repositories. Then try updating again.

Also try opening Ubuntu Software Center. I had a similar problem and when I opened the Software Center it told me that no software could be installed until the repos are repaired. I allowed it to repair and all was fine after that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .