I'm installing a few new Ubuntu Server 12.04 LTS servers, and they have two 512 GB SSDs. I want them to use software RAID 1 mirroring, so I was following this document religiously step by step:


To summarize the above official documentation:

to set up a software RAID 1 mirror in Ubuntu Server, you choose manual partitioning during the setup, and do this on each drive:

  • "swap" partition of roughly RAM size
  • "physical volume for RAID" partition for remaining drive size

After that, you set up the RAID 1 mirror using the RAID partitions on drive A and B, make it ext4 and containing the root filesystem partition.

Setup continues from there just fine.

One caveat: I was completely unable to select the "physical volume for RAID" as bootable. When I tried to do that in setup, it had no effect: I could press enter on the "make bootable" option all day long and nothing would ever change.

However, after install successfully completes, I have a big problem: the system won't boot! I get

Reboot and Select proper boot device
or Insert Boot Media in selected Boot device and press a key

What did I do wrong? Why can't I mark that "physical volume for RAID" partition bootable during Ubuntu Server setup? Is there some way for me to make the physical volumes for RAID bootable after the fact, perhaps from a live CD or something?

  • Here goes the bug report with regards to the documentation. And, the bug report about debian-installer.
    – jokerdino
    Nov 11, 2012 at 11:54
  • And since this is a bug, we would probably close this question as off-topic. Sorry about that. :-)
    – jokerdino
    Nov 11, 2012 at 11:58
  • I guess, but see my answer. If you want something that works, I have it. Nov 11, 2012 at 12:02
  • I'll see if I can get the Ubuntu docs team to update the documentation. And +1'ed the answer.
    – jokerdino
    Nov 11, 2012 at 12:08
  • Not sure I follow your question here. If Grub is installed to the MBR then the boot flags simply shouldn't matter at all.
    – Zoredache
    Nov 16, 2012 at 2:52

4 Answers 4


Well, I was able to proceed by deviating from the official install docs slightly.

Rather than manually configuring the free space on the two drives, I selected "automatically partition the free space" on each drive.

Note that this caused automatic creation of a 32 GB (equal to RAM size) swap partition, and one large ext4 partition. I changed the ext4 partition to RAID, then I was able to mark it bootable at last!

Ubuntu RAID 1 config

Note the little "B" next to the RAID partition on the first sda drive.

  • Alternatively you could boot from a CD and configure grub manually, but that's a little too involved to sum up in an answer. Too bad about the waste of disk space though.
    – wds
    Nov 11, 2012 at 12:12
  • 1
    @wds "too involved to sum up in an answer" What hath Ubuntu wrought?
    – jscott
    Nov 11, 2012 at 23:56
  • did you find a way to fix a system that already tried to boot and failed? I already spent a bunch of time setting one up and it'd suck to do it again :/ I guess I would have to boot off the livecd again, mount the raid and install grub manually.
    – 0x6A75616E
    Mar 1, 2013 at 7:46

While Jeff provided a solution that fixes the symptom, the underlying reason is a missing partition of type "biosgrub". The process described by Jeff creates one such partition (only 1MB in size).

It is advisable to create such a partition on both drives, if you would like to boot even if one drive failed.


After eating a little humble pie,

I have discovered the cause of my problem and, yes, as you can imagine, there is no such thing as a "new installer".

My problem was being caused by teh fact that I was using 3TB hard drives.

Anything larger than 2TB needs to be forced to GPT Partition table and the current partitioner in the installer is not able to do this or setup the partition for grub properly. All I needed to was setup my partitions in GParted, before I attempted the Instal. I have a GParted Live CD but you can use the Ubuntu Desktop Live DVD to boot from and use the copy or GParted in there.

Create the Partition table making sure it is GPT create a partition of at leats 1.0MB with no file system on it, and set its flag to 'biosgrub' (This is the important part)

create swap Partition and set its flag to 'raid' create the main Partition and set its flag to 'raid' Repeat for second disk.

Now when you run the 12.04.3 Installer, it will see the Partitions, and you just need to run the "Configure RAID" part, adding both the teh swap and main. go into the swap part of the array and go "use as" - swap area. go into the main part of the array and go "use as" - ext4, mount poit - / (root) no need to worry about bootable flags, exit and write to disk, Installation then works fine and grub is intalled fine at the end. This solution was found here: http://ubuntuforums.org/showthread.php?t=2109438

Again Apologies if I came on a little heavy, but it was doing my head in. I hope this helps.

  • I was experiencing the same issue by not being able to set bootable flag on 240GB SSDs so I created additional biosgrub partition on each disk. I Didn't set any boot flags and was able to complete setup. Thank you very much for the solution! Jan 24, 2014 at 6:27

Here is a step-by-step guide on how to configure a software raid 1 on 12.04. It has pictures for every step, so if you follow it exactly, you shouldn't have any problems:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .