I started using linux about a week ago and chose ubuntu 12.10 to start out with.

I ran it dual boot with windows 7. Played with it for about a week and everything was going great then I loaded up minecraft and noticed it was running poorly.

So I thought I haven't done anything with my graphics yet so why not try installing new drivers. I removed my current drivers then went out and downloaded it from amd and extracted it then ran it through the terminal.

Everything went fine and it was successful so I rebooted. By the time it loaded back up I got to the purple screen and heard the login sound then nothing. Just purple screen. I'm using a Radeon HD 6950 if that is relevant to the problem.

I tried using recovery mode, my boot loader is unaffected by all this, to remove the new drivers and reinstall the old ones but quickly realized I was over my head and didn't make any changes.

I know how powerful the terminal can be and I'm still a bit hesitant to really dive into it without some direction.


  • Im having similar trouble - unable to get to single user mode using init, but I think something like 'sudo aticonfig --initial -f' would be a good start. Nov 15, 2012 at 1:17
  • Personally I switched to the xorg-edgers ppa, they handle the latest updates for both closed and open source drivers and the x server. The binary drivers are usually updated within a few days. However it is bleeding edge, things can break. launchpad.net/~xorg-edgers/+archive/ppa Feb 21, 2013 at 13:59

1 Answer 1


Good on you for trying out Linux!

I had the same problem with my AMD Radeon HD 7770, and after a bit of research I found out that other people had been having problems with the update. It basically amounts to Ubuntu 12.10 not being compatible with the 12.10 AMD Catalyst driver.

You are going to have to download and install the Catalyst 12.11 Beta driver for it to work (updated driver now available at support.amd.com). The gist of the tutorial can be found over on wiki.cchtml.com, but I'll restate it here. If you encounter any problems, head over to the tutorial, it has some great troubleshooting advice.

Start off by removing your previously installed Catalyst/fglrx drivers. Everything will be done directly from the terminal, which can be accessed via Ctrl+Alt+T OR Ctrl+Alt+F1 (Ctrl+Alt+F7 to return back, out of tty, to Gnome). From the terminal, type the following:

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Once that's done, reinstall some of the components your Catalyst driver overrode:

sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases linux-headers-generic

If you're using a 64 bit architecture, install this too:

sudo apt-get install lib32gcc1

Now, install the 13.2 beta Catalyst driver from the AMD website (a newer driver may be available):

wget -c http://www2.ati.com/drivers/beta/amd-driver-installer-catalyst-13.2-beta6-linux-x86.x86_64.zip
unzip amd-driver-installer-catalyst-13.2-beta6-linux-x86.x86_64.zip
chmod +x amd-driver-installer-catalyst-13.2-beta6-linux-x86.x86_64.run

Create and install the .deb packages:

sudo sh ./amd-driver-installer-catalyst-13.2-beta6-linux-x86.x86_64.run --buildpkg Ubuntu/quantal
sudo dpkg -i fglrx*.deb

Before rebooting your computer, edit the ATI signature file via "nano" or "gedit":

sudo nano /etc/ati/signature


sudo gedit /etc/ati/signature

By replacing the "UNSIGNED" line with the following code:


Make sure to save before/on closing the file.

That will remove the AMD "Testing" watermark (which you will now never see) from the bottom right of your screen when you reboot (source).

Now go ahead and reboot your computer.

Last but not least, initialise your new driver, again from the terminal:

sudo amdconfig --initial -f

If this runs without a hitch, quickly test that everything is working as it should:


If you receive something like this as an output, you're all set:

display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 4550 (This line may be different depending on what graphics card you are using.)
OpenGL version string: 3.3.11566 Compatibility Profile Context (This line may be different depending on what graphics card and 
Catalyst version you are using.)

Remember, if you have any problems with the install, refer yourself to the tutorial on wiki.cchtml.com.

Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .