I am trying to install ubuntu 12.10 64bit using a liveUsb and I got this message :

cannot mount /dev/loop1 on /cow which shows up after clicking on "try Ubuntu before installing" or install Ubuntu".

I tried using nomodeset option and I ended up with this error :

initramfs) unable to find a medium containing a live file system

I used Startup Disk Creator


Did you wait for the persistence file to be created?

If not, this is a reasonable error since the file will be corrupt. That's why it worked when you used the option "Discard changes".

Mind that for a 4Gb persistence file it takes about 10 minutes to write it in a USB 2.0.

| improve this answer | |
  • I am not sure if I have waited or not. all I did is click erase the USB and then install. waited for everything to finish, pressed OK after it finished installing and restarted my PC. – Suhaib Dec 2 '12 at 2:35

Ok, I solved the problem.

All I had to do is to choose the "Discard changes after shutdown" option when I was using Start up disk creator program to create my LiveUsb.

Is this a bug ?

| improve this answer | |

Run again Universal USB installer and this time make sure you check the option format drive (usb) when using universal usb installer. That's all.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.