I purchased an HP laptop with the Qualcomm Atheros AR9565 (QCWB335) wireless adapter. I understand that this adapter is currently not supported on Ubuntu 12.04 and there is no way to get wireless access.

I installed compat-wireless-3.6.6-1 ath9k driver and it didn't work, lshw -C network still showed *-network UNCLAIMED after reset.

How can I figure out when Ubuntu will have driver for AR9565? Is there a workaround to get wireless working somehow?

6 Answers 6


Your device is covered in this package: http://www.orbit-lab.org/kernel/compat-wireless-3-stable/v3.6/compat-wireless-3.6.6-1-snpc.tar.bz2

The files with extra letters, in this case snpc, are pre-patched to add newer devices and, sometimes, features. Yours is a good example.

  • This worked. After installing the updated Ubuntu driver, my wireless adapter appeared, but was hardware disabled. I had to install Windows 7 in a side partition and get the Wireless working there first. Then, after I booted into Ubuntu, wireless was working.
    – Victor L
    Nov 20, 2012 at 14:19
  • Very glad it's working. Don't forget to re-compile after a later kernel version is installed by Update Manager.
    – chili555
    Nov 20, 2012 at 16:44

Here's one way to solve this. I myself had the same problem as mentioned here. I followed two posts on ubuntuforum by anoop-n2 and chili555, and kind of did a mix of things, which can be outlined as follows:

You need to have linux-headers-generic and build-essential installed, try

sudo apt-get install linux-headers-generic build-essential

which will turn out to be of the newest version if those are already there.

The following should be done in a terminal as root:

sudo -i
wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.9-rc4/compat-drivers-3.9-rc4-2-s.tar.bz2
tar xvf compat-drivers-3.9-rc4-2-s.tar.bz2
cd compat-drivers-3.9-rc4-2-s/
./scripts/driver-select ath9k

Now this will probably give the following error:

error: redefinition of ‘kref_get_unless_zero’
include/linux/kref.h:47:32: note: previous definition of ‘kref_get_unless_zero’ was here

In this case, open the header file, and find the entire block of the function:

static inline int __must_check kref_get_unless_zero(struct kref *kref)
    return atomic_add_unless(&kref->refcount, 1, 0);

Next comment out the entire block of the function using line comment (put // in front of each line) or block comment in c as,

/*static inline int __must_check kref_get_unless_zero(struct kref *kref)
    return atomic_add_unless(&kref->refcount, 1, 0);

then type the following commands one by one:

make install

Then load the driver using

modprobe ath9k

or reboot the system. Afterwards the wifi should be working.

  • This really worked! I had the same problem when installing Ubuntu 15.10 on my Dell Inspiron 20. It wouldn't connect to the WiFi because it held the old broken packages which were the residue of the Ubuntu 14.10 i had. Therefore, it failed. But this fixed it well!! +1 from me!
    – skybldev
    Mar 24, 2016 at 15:47
  • I'm trying this approach with my Asus R510Z, and this error shows up during make: "ERROR: compat-drivers by default supports kernels >= 2.6.24, try enabling only one driver though" Wondering what's the solution?
    – Xun Yang
    Jun 21, 2016 at 7:43

The compat-wireless package will probably require adding your pci.id to the pci.c file as well as some other changes, similar to this: http://ubuntuforums.org/showpost.php?p=12201881&postcount=35

Did you do that? Learn your pc.id with:

    lspci -nn | grep 0280

There may be a version of compat-wireless that includes your device. If you'll post the details, we'll be happy to assist you.

  • I did not make any custom modifications to the code yet. I'm guessing the pci.id for my device is 36 from 0a:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:0036] (rev 01). It is currently not in the ath_pci_id_table. I'll try to add it and see what happens.
    – Victor L
    Nov 11, 2012 at 15:50
  • After adding 36, the wireless is still not working as before. It is still UNCLAIMED. The only change I see is that the wireless light is always red on my laptop (off). I cannot make it white by pressing Fn-F12. However, doing sudo rfkill list all shows that nothing is blocked.
    – Victor L
    Nov 11, 2012 at 20:30

I was able to fix this issue by running the following commands.

sudo apt-get autoclean
sudo apt-get update
sudo apt-get dist-upgrade

What I found that this upgrades the kernel from to

Hope that helps...


I would try to use Linux Mint, as I was having problems with this chip-set also in my Debian dist. One of the people suggested Mint and it came up working on the first install, not just wifi, but all the communication stuff. Maybe time to switch distro's!

I did resolve my problems with a backport and now that it's installed I have no problems with the AR9565 set. Might look at available backports to see if there is a hint about support there.

It is cheap to download and burn a DVD with Mint live on it to just boot and see if it's supported, instead of banging your head. I'm confident that it will support yours, because it supports mine! Also, anyone you speak with will understand that the chip-set is supported somewhere in the Linux world and not spend half of your time debating if it's supported or not. Plus it's nice warm willies to have it come up and work after all the work you put into it!


Qualcomm Atheros QCA8172 on Lenovo G505 - Ubuntu 13.04 works perfectly on Lenovo G505 - make sure you do a clean install of Ubuntu 13.04 vs a 're-install'. Wi-Fi/LAN keyboard mouse everything works perfectly.

I'd spent all day looking for drivers, but the ones included in ubuntu 13.04 already support Qualcomm Atheros QCA8172 network driver card. Cheers

  • 5
    The question is about the AR9565 (QCWB335) device. You're describing another one, so this does not apply here, unless you can show that the support for the one in the OP is also available in 13.04 now.
    – gertvdijk
    Aug 22, 2013 at 5:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .