5

Recently I installed Ubuntu 12.10 alongside Windows in a separate partition with ext3 file format.

Everything worked fine when I installed 12.10 at first. But after I updated the packages (which was around 70mb), my Wifi connections aren't shown. I can see bluetooth working fine, but I cannot see any active Wireless connections (i have checked the "Enable networking" also).

  • 1
    Please run the terminal command: lspci -nn. Please edit your question to add the details of your wireless card. – chili555 Nov 10 '12 at 15:11
  • Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Nov 10 '12 at 17:08
  • Have you tried turning it on from the terminal? sudo ifconfig wlan0 up – tapan Nov 10 '12 at 18:14
9

I had a similar problem, it was resolved by following the steps here

http://www.upubuntu.com/2012/10/how-to-fix-unity-and-wireless-problems.html

WiFi Stops Working After Upgrading To Ubuntu 12.10 (Broadcom Wireless cards)

You can fix wifi problems using two methods:

  • Either connect to the internet via wired connection and run this command:

    sudo apt-get update && sudo apt-get upgrade

Then reboot your system.

  • Or use the following commands:

    sudo apt-get install linux linux-headers-generic kernel-package

    sudo apt-get install --reinstall bcmwl* firmware-b43-lpphy-installer b43-fwcutter

Finally, reboot your system.

If that didn't help, try these commands:

sudo apt-get remove bcmwl-kernel-source

sudo apt-get install firmware-b43-installer b43-fwcutter

sudo reboot
| improve this answer | |
  • Worked for me too – Oussama Dec 28 '12 at 14:05
  • This worked for me on a standalone install of 12.10. – jimchristie Mar 24 '13 at 14:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.