36

This question already has an answer here:

Note: The legacy Skype for Linux application (v4.*) is now discontinued and was removed from Canonical’s partner repositories, so this question and its answers are obsolete. Please refer to a newer answer of our canonical Skype installation question.


I am receiving the following message while I am trying to install Skype:

nidhin@ubuntu:~$ sudo apt-get update
nidhin@ubuntu:~$ sudo apt-get install skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin but it is not installable
E: Unable to correct problems, you have held broken packages

How can I fix this?

marked as duplicate by David Foerster, Eric Carvalho, user364819, karel, Charles Green Jul 9 '17 at 3:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

10 Answers 10

42

12.10 and newer

I had that same issue and what helped was to enable the 32-bit architecture by doing this:

sudo dpkg --add-architecture i386
sudo apt-get update

then I was able to install skype via the Canonical Partner Repository:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype
  • lsb_release -sc - learn something new every day – user51157 Apr 21 '15 at 19:48
  • 2
    still getting the same error. skype-bin – SY_13 Feb 27 '16 at 7:30
32

First of all you have to enable i386 architecture before running the below commands on your Ubuntu 64 bit system.

sudo dpkg --add-architecture i386

Then run the below commands on terminal to install skype.

Ubuntu 13.10

sudo sh -c "echo 'deb http://archive.canonical.com/ saucy partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype

Ubuntu 14.04

sudo sh -c "echo 'deb http://archive.canonical.com/ trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype
  • 7
    if it still shows the error skype : Depends: skype-bin after following this answer, choose a diffrent download server from software and updates. – Avinash Raj Apr 20 '14 at 16:00
  • 1
    Should one remove the i386 architecture after installing Skype? Would the x64 and x86 architectures in dpkg muck things up later on? – blong Aug 11 '15 at 3:50
3

I suggest to remove skype-bin first completely and install Skype as follows.

Run following commands in Terminal

sudo apt-get remove skype skype-bin

sudo apt-get install libxss1  

wget http://www.skype.com/go/getskype-linux-ubuntu-64/skype-ubuntu-precise_4.1.0.20-1_amd64.deb

sudo dpkg -i skype-ubuntu*.deb
3

 12.10 and above and in particular 17.04:

https://www.skype.com/en/download-skype/skype-for-computer/

Download the deb package

If it isn't installed already install gdebi :

sudo apt update && sudo apt upgrade
sudo apt install gdebi

then cd to the Downloads directory and run gdebi for the downloaded deb:

sudo gdebi –n skypeforlinux-64.deb

(Or for an approach that doesn't even require installation of any extra software) :

sudo dpkg -i skypeforlinux-64.deb

you may instead just right click on the downloaded file go into properties and set the default program to open this sort of file to gdebi (which is recommended in the meantime in 17.04) and then simply double click the file and when gdebi opens and finishes loading the file click install (you will be prompted for your password)

  • actually when you run gdebi in the terminal it's not the graphical app it's the termianl text only one. I don't know why that is but I think it's pretty clever. I agree dpkg is enough IF it does exactly the same thing. I didn't know if it did or not but I'm perfecty willing to believe that. – tatsu Jun 12 '17 at 8:21
  • ah thanks for clarifying that! I didn't edit because I don't use gdebi so wasn't sure – Zanna Jun 12 '17 at 8:28
2

skype is not from ubuntu.it is a third party software supported by canonical foundation so edit your source.list using

$sudo gedit /etc/apt/source.list

then add the following link into your source list

deb http://archive.canonical.com/ubuntu $(lsb_release -sc) partner
deb-src http://archive.canonical.com/ubuntu $(lsb_release -sc) partner

$(lsb_release -sc) replace with your ubuntu name. Save it. Then update your repository using

$sudo apt-get update

now run the following command to install skype

$sudo apt-get install skype

this will install skype and skype.bin.

0

Try these commands:

sudo apt-get install libxss1 
cd /tmp 
wget http://www.skype.com/go/getskype-linux-ubuntu-64/skype-ubuntu-precise_4.1.0.20-1_amd64.deb
sudo dpkg -i skype-ubuntu*.deb

Source: http://www.tecmint.com/install-skype-4-1-in-ubuntu-xubuntu-linux-mint/

0
  1. download skype package from here
  2. install it with double-click
  3. open nautilus in /usr/share/applications/
  4. edit skype.desktop (fix for sound issue) and replace line:
    Exec= skype %U with Exec=env PULSE_LATENCY_MSEC=30 skype %U

  5. drag skype.desktop and drop on unity bar (this will make opening same skype instance after closing window)

Full code for the .desktop file can be found at: skype.desktop

  • Additionally, if you want the sound issue fix also when starting Skype via the Alt+F2 mini-terminal and typing skype, do this: create an executable file /usr/local/bin/skype with first line #!/bin/bash and next line env PULSE_LATENCY_MSEC=30 /usr/bin/skype. Make sure with which skype that the skype command now refers to your new file. – tanius Feb 19 '14 at 1:18
0

This is common problem in 64 bits for installing Skype

First a downgrade is required and done with the following: create the 'preferences' file:

sudo vi /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade

Then you may install packages that complained about dependencies, like
sudo apt-get install ia32-libs-multiarch, or sudo apt-get install ia32-libs.

Finally, you should remove the file you just created:

sudo rm /etc/apt/preferences

Now download Skype From Official website(skype.com ) for multi architecture

then open the downloded package from software center then you should able to install skype

0

While other answers here provide the correct way to install skype, you might still get the same error (I did).

Running aptitude install skype might be more useful in finding what's causing the problem.

One possible cause is a system upgraded from 14.04 to 16.04.
Some packages from ubuntu 14.04 have version numbers that when compared to those in 16.04 are considered "higher". E.g.:

  • ubuntu 14.04: libdrm2 2.4.67-1ubuntu0.14.04.1
  • ubuntu 16.04: libdrm2 2.4.67-1

When upgrading from 14.04 to 16.04 these packages are not upgraded (and won't be upgraded later either) because ubuntu thinks, for example, that 2.4.67-1ubuntu0.14.04.1 is greater than 2.4.67-1.

This causes problems when trying to install their i386 counterpart needed by skype because the i386 version wouldn't match the amd64 one already installed (which where leftovers from 14.04).

The same problem applies to libdrm-intel1, libdrm-radeon1, libdrm-nouveau2, libdrm-amdgpu1, libdrm-dev, libuv1. This list is not exhaustive.

This can be solved by creating a file (e.g. /tmp/pin.txt) containing:

Package: *
Pin: release n=*
Pin-Priority: 1001

and running:

sudo apt-get -o Dir::Etc::Preferences=/tmp/pin.txt dist-upgrade

Warning: This will install the version available in the repositories for ALL packages. Be careful if you have installed any packages from somewhere else (just make sure apt-get is not trying to downgrade anything when prompted for confirmation).

-1

Install Synaptic if you don't have it, Open it, then go to Edit > Fix Broken Packages. After that try to install Skype.

  • Thank you for the suggestion..I have done as you suggested however I am still getting the same error message – Nidhin Nov 10 '12 at 9:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.