5

Screen brightness is not changing on my ACER 5742 notebook. I have Ubuntu 10.10 installed inside Windows 7 OS. Hotkeys are used for changing brightness. Though, a bar displaying brightness level appears on screen but there is no actual change in brightness of screen.

6

This worked for me. Run:

gksu gedit /etc/default/grub

Change the line:

GRUB_CMDLINE_LINUX=""

Make it say this instead:

GRUB_CMDLINE_LINUX="acpi_osi=Linux"

Then run sudo update-grub and reboot. Credit to this guy.

1

Modifying both these lines in /etc/default/grub worked for my 4810T:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"
0

I had the same problem with my Acer 5749. The bar displaying the brightness would show that the brightness was moving up and down, but the actual brightness wasn't changing.

In /etc/default/grub, I tried just:

GRUB_CMDLINE_LINUX="acpi_osi=Linux"

But it didn't work. Then I tried:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"

and that did work.

In both cases I edited the lines in /etc/default/grub then ran sudo update-grub and rebooted.

Another way, by editing just one line:

Finally I tried just:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

and that worked too. I put the other line back to how it was originally and the brightness control still works after running sudo update-grub and rebooting again:

GRUB_CMDLINE_LINUX=""
  • I'm glad I posted this because the hard drive failed and was replaced. Now I need to fix the brightness problem again. I'll try just editing the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub and running 'sudo update-grub'. – Chris Moore Jul 24 '12 at 23:49
  • That worked. . . – Chris Moore Jul 25 '12 at 0:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy