3

I previously enabled the display of the Computer, Home, Trash, and Network Servers icons on the desktop on Ubuntu 12.04, probably using MyUnity. Today, I installed a custom icon set and after rebooting, all four icons disappear from the desktop. I switched back to the default icon set, all of this using MyUnity, and rebooted. The icons are still missing.

I can get the icons to reappear by opening dconf Editor and disabling the display of icons on the desktop and re-enabling the display of icons. I can also get them to show up by killing nautilus and restarting it. They again disappear after reboot, regardless of the icon set selected.

I've tried deleting all of the Nautilus, Unity, and Compiz configuration folders and running the --reset options as appropriate for each from the command line.

I'm running out of ideas to fix this issue. Any thoughts?

2

Maybe nautilus has been disabled to start at each session.

You can try following this answer:

Go to Startup Applications, click "Add" and insert the command nautilus -n. This way you can have nautilus autostarting in the background even if hide-desktop-icons feature is in use.

1

It seems nautilus has not been started. Try this in Terminal

user@ubuntu:~$ nautilus &

hit enter. Also add this command to run on each login. Probably using Startup Program, or other ways. Google it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.