I installed the nvidia driver (installed the ubuntu-x-swat ones, updated them, got the updates for them, installed bumblebee. I restarted everytime I did those steps, so no, i don't simply need to 'restart X'. I tried to run things using bumblebee, but bumblebee was like "can't access GPU driver". So I ran nvidia-settings, it said the drivers weren't in use, so I ran "sudo nvidia-xconfig", then restarted.

Now, my login screen looks differently than it did before: it asks me if I want to load: "GNOME, GNOME - no effects, Cairo Dock - GNOME, System Default, or Ubuntu" when I log in,

but WORST OF ALL: i no longer have any kind of GNOME/unity GUI. There are no title bars above any windows, no close/minimize/maximize buttons. The unity bar is gone, and will not show up when I call it. And the top status bar is also no longer there. I can't close any windows or open anything that I don't know the command for

UPDATE: I ended up reinstalling Ubuntu, and doing the following:

1) Installed the linux sources and headers. (These are required to build the driver)

    sudo apt-get install linux-source linux-headers-3.5.0-17-generic

2) Add a PPA containing recent drivers: (How recent are these?)

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

3) Add the Stable Bumblebee Releases PPA and install Bumblebee using the proprietary NVIDIA driver:

    sudo add-apt-repository ppa:bumblebee/stable
    sudo apt-get update
    sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic

And now things work. My graphics card is by default off. If I run glxspheres I get ~50fps, and if I optirun glxspheres I get ~150 fps. When I run nvidia-settings or optirun nvidia-settings, I get this: not many options

  • I recommend moving your solution to be an Answer that you accept. Thanks for following up with your solution :) Mar 3, 2013 at 3:42

1 Answer 1


There are some problems with the nvidia drivers that cause this problem. It seems to be a problem with the accelerated drivers and how unity/X tries to use the GPU. Reverting to the nouveau drivers should fix the problems, or you can try nvidia-current or nvidia-current-updates. I haven't had a lot of luck so far with the newer 304.x driver modules.

  • How do I revert to the nouveau drivers? What is the terminal command to do so?
    – Noel
    Nov 13, 2012 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.