I'm having a problem with Emacs when I SSH from my Ubuntu 12.04 laptop to another Linux machine. FWIW, I believe the remote machine is using SUSE Enterprise Server 10 SP2, which is possibly quite old. I connect using ssh -X <server>. When I run Emacs, I get the error messages

Warning: Cannot convert string "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*" to type FontStruct
Warning: Cannot convert string "-*-helvetica-medium-r-*--*-120-*-*-*-*-iso8859-1" to type FontStruct

and Emacs is full of boxes instead of text characters, as shown below.

enter image description here

I've tried flushing my local font cache with sudo fc-cache -f -v but that didn't help. Ideas? Thanks in advance!


I found that this solved my emacs problem


  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – fossfreedom Dec 6 '12 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.