I'm trying to get Xen 4.0.1 run as dom0 on a fresh/clean install of 10.10 desktop (x64).

Followed the step by step tutorial at http://wiki.xensource.com/xenwiki/Xen4.0

I have the pvops kernel in /boot, also included the ext4 fs support by recompiling the kernel by :

make -j6 linux-2.6-pvops-config CONFIGMODE=menuconfig
make -j6 linux-2.6-pvops-build
make -j6 linux-2.6-pvops-install

Here's my grub entry :

menuentry 'Xen4' --class ubuntu --class gnu-linux --class gnu --class os {
        insmod part_msdos
        insmod ext2
        insmod ext3
        set root='(hd0,msdos1)'
        search --no-floppy --fs-uuid --set 2bf3177a-92fd-4196-901a-da8d810b04b4
        multiboot  /xen-4.0.gz dom0_mem=1024M loglvl=all guest_loglvl=all
        module     /vmlinuz- root=UUID=2bf3177a-92fd-4196-901a-da8d810b04b4 ro
        module     /initrd.img-

blkid /dev/sda1 gives the :

/dev/sda1: UUID="2bf3177a-92fd-4196-901a-da8d810b04b4" TYPE="ext3"

My partition shemes is :

/boot (ext3) (/dev/sda1)
/ (ext4) (/dev/sda5)

Whatever option i've tried i end up with :

mounting none on /dev failed: no such file or directory

And message complaining that it cannot find the device with uuid ...

Edit : also tried to put root=/dev/sda1 (and /dev/sda5) also put acpi=off noapic nolapic

Always fall back to initramfs busy box. When in initramfs i try to see whether there is a /dev/sdXX and nothing, neighter /dev/device*.

my /lib/modules/ only contains a very few amount of files (in comparison to the generic file); did I miss something with the modules ?

This pv ops is taking my hairs out, if somone has a clue ...

  • Great Help. In my case, for XCP and Ubuntu 11 I did this: menuentry "XCP release 1.6" --class gnu-linux --class gnu --class os { insmod part_gpt insmod ext2 set root='(hd1,gpt1)' search --no-floppy --fs-uuid --set=root 90588eec-1d22-461e-9937-4d33994832af multiboot /boot/xen.gz mem=1024G module /boot/vmlinuz-2.6-xen root=/dev/sdb1 ro xencons=hvc console=hvc0 console=tty0 quiet vga=785 splash module /boot/initrd-2.6-xen.img } Thanks for the help.
    – Hernan
    May 7, 2013 at 14:03

1 Answer 1


You have to change you root partition in the first module parameter (module /vmlinuz- root=). You have to change it to /dev/sda5 (Becase in the current entry you have entered the boot partitions uuid).

You can get the uuid from blkid /dev/sda5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.