Yesterday, I freshly installed Ubuntu 12.04 and it worked fine, but today when I booted the computer something strange happened. The Unity Launcher disappeared!

Any help would be appreciated.

  • Which Launcher icon did disappear? Did the Launcher disappear completely? It would help if you gave us a screenshot. – Томица Кораћ Nov 8 '12 at 11:21
  • I think the OP meant the Unity launcher is missing not just a specific launcher icon. @user, have you tried moving the mouse to the left edge of the screen? Maybe it is set to autohide? How about pressing the Super key? – Peachy Nov 8 '12 at 13:01

You need to launch CCSM and make sure that Enable Ubuntu Unity Plugin is ticked.

If you don't have CCSM installed, do the following:

  1. Press Ctrl+Alt+T to launch the Terminal.

  2. Type the following command and press Enter

    sudo apt-get install compizconfig-settings-manager
  3. Now, launch CCSM by running this command from the Terminal:

    sudo ccsm
  4. In the CCSM window, select Desktop → Ubuntu Unity Plugin.

    enter image description here

  5. In the next window, make sure Enable Ubuntu Unitu Plugin is checked.

    enter image description here

| improve this answer | |
  • Hmm, I get to the sudo ccsm step, but the entire CompizConfig Settings Manager window us unresponsive to clicks. – Peter Dec 1 '17 at 22:08

I had pretty much the same problem under 12.04 (64 bit). Unity was slow with my aged GPU, so I was using Unity 2d as my desktop for months. For no apparent reason, it suddenly refused to display launchpad and title bar (for all users). Autohide was disabled. Reenabling Unity in CCSM as sugggested above was part of the solution, but none of the other measures suggested in several other related threads, including, but not limited to:

  1. Reinstalling unity

  2. Reinstalling ubuntu desktop

  3. Removing all relevant (e.g. compiz, gconf, etc.) configuration information

helped me to completely resolve these symptoms.

unity --reset

would not work for me. After delivering a variety of error and information messages, it would always hang at:

Setting Update "run_key"

as shown in the log posted in the thread titled "unity has vanished" for unity run with no arguments.

I noticed that the error message delivered by:

/usr/lib/nux/unity_support_test -p

was similar to some of the errors reported by unity --reset:

error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory.

After extensive searching, I found the following solution:

  1. Get the path of libGL.so.1 by using the command locate libGL.so.1.

  2. Add a link to the library in /usr/lib/ as shown in the following example:

    sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib

    (courtesy of J.D. Bartlett)

  3. Restart the computer.

This not only allowed both unity_support_test-p and unity --reset to run, it also allowed Unity 2d to start. Like the author of the above-mentioned post, I have no idea what caused my problems. I am also still not sure whether the link is a complete solution, or whether I should reinstall the graphics libraries completely, as described by Cynical here.

| improve this answer | |
  • I tried a dozen solutions, athe missing libGL.so.1 link was the answer. Thanks. – Bruce Barnett Feb 24 '14 at 16:21

I had the same problem, but for me the fix was:

sudo dconf reset -f /org/compiz/
setsid unity

which I found in this thread:


If the first two answers don't work for you (they didn't for me) hopefully this will help.

| improve this answer | |

Similar symptoms: 12.04, launcher and menu bar disappear during a logged-in session. Oddly, they're still responsive, just invisible.

Workaround for me: use ctrl-alt-del to logout (have to hit it twice?); log-out dialog appears, along with the missing menu and launchers. Cancel logout.

Using built-in driver for Nvidia graphics.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.