135

Where do I get the MPEG-4 AAC decoder, and the H.264 decoder.

How to install them and play the multimedia?

1
  • This thread is hilarious, everyone has as different proposition of packages to install and I don't think any of them work, I haven't found a combination that works yet anyhow. I gave-up and loaded an MP3 stream instead.
    – Coder Guy
    Feb 22, 2021 at 1:05

7 Answers 7

154

ubuntu-restricted-extras package allows users to install ability to play popular non-free media formats, including DVD, MP3, Quicktime, and Windows Media formats.

To install ubuntu-restricted-extras package:

  1. Open a terminal by pressing Ctrl+Alt+T.

  2. Run this command:

     sudo apt-get install ubuntu-restricted-extras
    
  3. Alternatively, you can install the package via Software Center by launching it via Dash and searching the package and clicking on Install.

enter image description here

Also, try installing libavcodec54 libav-tools and ffmpeg with this command:

sudo apt-get install libavcodec54 libav-tools ffmpeg

EDIT: Ubuntu 20.04

In Ubuntu 20.04, you want libavcodec58 instead of 54:

sudo apt-get install libavcodec58 ffmpeg
11
  • 8
    Also: Package libav-tools is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: ffmpeg:i386 ffmpeg E: Unable to locate package libavcodec54 E: Package 'libav-tools' has no installation candidate
    – Shayan
    Aug 27, 2019 at 12:43
  • 1
    @Nathan I wrote these comments back when I was using 16.04.3 and still am using it.
    – Shayan
    Aug 12, 2020 at 5:12
  • 5
    Ah, okay. As edited-in above, I solved this for Ubuntu 20.04. For Ubuntu 20.04, you've gotta do sudo apt-get install libavcodec58 instead of 54 Aug 12, 2020 at 5:19
  • 8
    Ubuntu 20.04 libav-tools has no installation candidate
    – John Dee
    Jan 3, 2021 at 7:08
  • 1
    For me on 20.04 sudo apt-get install ubuntu-restricted-extras sudo apt-get install libavcodec58 ffmpeg Finished the job, video app is now playing videos. Jan 25, 2021 at 11:45
33

Support to decode MPEG-4 AAC is provided by gstreamer1.0-libav and to decode H.264 there is ffmpeg:

$ sudo apt-get install gstreamer1.0-libav ffmpeg

For more information have a look at the Ubuntu Documentation.

3
  • 4
    Excellent on Ubuntu 20.04.1, Thanks.
    – QMaster
    Sep 10, 2021 at 23:41
  • Besides these packages I installed libavcodec58 package too, I face an issue into Ubuntu 20.04 May 6, 2022 at 23:58
  • 2
    best solution on Ubuntu 22.04
    – GNassro
    Aug 29, 2022 at 13:13
25

The other answers seems to work on older versions but today when I was installing the same on clean install of Ubuntu 18.04 using Peachy's answer I got lot of errors. Using these commands I installed that in Ubuntu 18.04 LTS successfully.

sudo apt install libdvdnav4 libdvdread4 gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly libdvd-pkg
sudo apt install ubuntu-restricted-extras

Note: In 20.04, libdvdread4 has been updated to libdvdread7, and in 20.10, it's now libdvdread8 (see Ubuntu packages for the current version).

4
  • 1
    This actually works for 18.04. Thanks bro!! Sep 16, 2018 at 7:47
  • I use Ubuntu Studio 18.04.1 LTS, and I have installed all the pieces of software you mentioned here, but... The problem is still the same! VLC player can play those videos but not Parole. So...
    – Juan
    Feb 9, 2019 at 0:34
  • This should be the accepted answer. Dec 1, 2019 at 17:48
  • 3
    This also worked for Ubuntu 20. I had the same issue with a new install
    – dannypaz
    Apr 23, 2020 at 23:37
9

Unfortunately none of these options seem to work on Ubuntu 16.04. I get a python 3.5 message for searching MPEG-4 AAC in one of the videos I try to play. None of the above fixing the missing codec.

A fine workaround is to install VLC:

sudo apt-get install vlc

(or from software center)

Update: found a fix:

sudo apt-get install gstreamer1.0-plugins-bad

This made sound work for Totem (Video)

Update: Try going to 'Software & Updates' and enabling the checkbox for 'Software restricted by by copyright or legal issues'. Then allow Ubuntu to update after clicking the close button. You should now be able to run:

sudo apt-get install ubuntu-restricted-extras

You'll also have to accept the EULA's terms and conditions before continuing.

5

Beware of the audio-only gstreamer bug

Hearing only audio on H.264 playback with an otherwise black video screen was reported as gstreamer1.0 bug #1562875.

Luckily, this bug can easily be resolved by issuing the following command once:

$ rm -R ~/.cache/gstreamer-1.0

This will take effect after restarting the application.

2
  • I didn't help to me! I use Ubuntu Studio 18.04.1 LTS and Parole 1.0.1.
    – Juan
    Feb 9, 2019 at 0:36
  • 1
    It helped and saved me after two days of researching. I was trying to play GTA SA on Ubuntu 20.04. Thanks a lot! Mar 12, 2022 at 11:25
1

In the last Ubuntu ver 14.04 , 14.10 the best way for setup them is :

To install ubuntu-restricted-extras package:

Open a terminal by pressing Ctrl+Alt+T.

sudo add-apt-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install ffmpeg gstreamer0.10-ffmpeg libavcodec-extra-53 libavcodec53

and N-joy

0

In my case I also needed intel-media-va-driver-non-free on top of the above answers
¯\_(ツ)_/¯

Not the answer you're looking for? Browse other questions tagged or ask your own question.