I've seen lots of stuff about this error on the internet, but had no luck implementing a solution. I'm trying to use Likewise-Open to join an Ubuntu Server 12.04 machine to a Windows Active Dicrectory domain controller and having absolutely no luck. I run: sudo domainjoin-cli join my.domain.gob ADMINISTRATOR and get back (after putting in the admin password):

Error: DNS_ERROR_BAD_PACKET [code 0x0000251e]
A bad packet was recieved from a DNS server. Potentially the requested address does not exist.

I have heard that WAD insists on being your only nameserver, and in attempts to make that work, I've tried editing /etc/resolv.conf and /etc/network/interfaces but none of that has worked either. Ideas?


Adding Active Directory machine as the primary DNS server solved this for me.

You may also want to modify /etc/resolv.conf by adding entries for both your domain name and Domain Controller.

I also recommend you install WINS on your DC in addition to DNS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.