After updating my system today, Ubuntu's doesn't display correctly. The desktop was working properly before, but now it looks like this:

enter image description here

I had to use the terminal to run Synaptic package manager, so I could view the update history, which is as follows:

Commit Log for Wed Nov  7 11:50:36 2012

Upgraded the following packages:
linux-image-generic ( to

Installed the following packages:
linux-image-3.5.0-18-generic (3.5.0-18.29)
linux-image-extra-3.5.0-18-generic (3.5.0-18.29)

Prior to this issue, the last active driver was nvidia-current-updates, version 304.51. I tried using the nvidia-current driver, version 304.51.really.304.43 instead, but the problem persists.

I tried running nvidia-settings from terminal, so I could try configuring something, but the application informs that the Nvidia driver is not being used.

As the x-swat repository has nothing for Quantal, I desperately used the unstable x-edgers repository and upgraded, but to no avail; so I purged it.

The display should normally be full HD, but the only available resolutions now are 1024x768(4:3) and 800x600(4:3).

The system is a Dell XPS-L702X, with NVIDIA GeForce GT 555M graphics, and a 17" screen.

How can I fix this problem?

Update: I tried using the Nouveau third-party driver and this fixes the issue. However, if you have any idea how to get the Nvidia drivers working properly with the latest kernel, please share; as I've noticed some videos playing very slowly on the system, though I'm not sure exactly why.

closed as off-topic by Olli, Braiam, souravc, Eliah Kagan, BuZZ-dEE Mar 3 '14 at 16:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Olli, Braiam, souravc, BuZZ-dEE
If this question can be reworded to fit the rules in the help center, please edit the question.


After the update of kernel 3.5.0-18 was issued my installation didnt work and nvidia.ko was not build

I needed to install the headers manually and then it was "ok" though compiz acted unstable in the first minute.

sudo  apt-get install linux-headers-3.5.0-18
sudo  apt-get install linux-headers-3.5.0-18-generic
sudo  depmod -a
sudo  modprobe nvidia
sudo  /etc/init.d/*dm restart

It may be necessary to update nvidia-current too

sudo apt-get remove nvidia-current
sudo apt-get install nvidia-current

Anyway - I never ever had so many problems with nvidia_current as with 12.10

Ubuntu must have killed all quality control employees - shame on you!

  • With headers installed & running sudo mobprobe nvidia, I get error FATAL: Module nvidia_current not found. ALso, when running sudo /etc/init.d/*dm restart` it reports that no module was found for running the kernel. Upon restart it returns to it's previous state, then I had to switch back to the Nouveau driver, to fix it for now. – fatboytall1 Nov 8 '12 at 11:14
  • matching headers are installed 100%? dpkg -l|grep headers should list 4 packages(old kernel+new kernel) perhaps apt-get remove nvidia-current;apt-get install nvidia-current to get an up2date version – GLenn Nov 8 '12 at 11:14
  • I have 304.51.really.304.43-0ubuntu1 installed – GLenn Nov 8 '12 at 11:20
  • Ok, so I removed & re-installed nvidia-current, then re-ran sudo modprobe nvidia, & it now works. I'm using the 304.51.really.304.43-0ubuntu1 too. I briefly tested the video playback again, & it appears to be working much better. – fatboytall1 Nov 8 '12 at 11:24

Had the same problem after updating this morning. Found a workaround what will useful at least for a short period.

Right-click and open screen-settings, then you will be able to select All-Settings and there select Software-Sources.

In this box select the tab Additional-Drivers. Here you will be able to select different display drivers, for me the second one works fine. Problem is... those are not the Nvidia drivers and will perform less, but at least it works.

Update: got new problems with VirtualBox combined with the OpenSource drivers. Went back to Nvidia drivers and kernel 3.5.0-17 , thanks Brad your solution did work great.

  • Thanks, it works now. But I prefer the Nvidia driver, as I've had slight issues with the third party one in the past; but it works nonetheless, until they provide an update. – fatboytall1 Nov 7 '12 at 18:59

You can switch back to your previous kernel by: 1. When you reboot, hold down the left shift key and get into the grub menu. 2. Select "Advanced options for Ubuntu" 3. Choose the 3.5.0-17 kernel and hit return to boot up using that kernel.

It would be helpful if you could also file a bug for this issue.

  • Thanks, very good suggestion, but I kinda love having the latest kernel/stuff, so I'll stick to the Nouveau driver. – fatboytall1 Nov 7 '12 at 21:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.