I have Ubuntu 12.04 LTS on a Toshiba Satellite M115 laptop. The brightness control doesn't seem to work with the "brightness and lock" setting or fn+f6 and fn+f7 (which usually works in Windows). How can I adjust the brightness and/or access different power settings, so my computer isn't running on full power all the time?

6 Answers 6


I am not familiar with your particular model, but you can try some of these 'solutions'.

Add acpi_backlight=vendor to grub:

Open terminal (Ctrl+Alt+T) and type:

gksudo gedit /etc/default/grub

You will find this line in the new opened window:


Change it to:


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Note your entry may be different - only add the acpi_backlight=vendor.

After doing that, do:

sudo update-grub

If that does not get the Fn+F6 and Fn+F7 keys working, you can do this via the system settings as seen below:

System settings

Brightness and lock

  • I tried both of your suggestions and neither worked. Thanks anyway. Nov 8, 2012 at 3:58
  • @TempleOntherat - there may be something more significant than the Fn keys now working then. You may want to file a bug.
    – cprofitt
    Nov 9, 2012 at 0:19
  • @cprofitt- Sorry, I'm new to Linux and Ubuntu. Would you post a link where I could read how to do that? Nov 9, 2012 at 2:30
  • help.ubuntu.com/community/ReportingBugs says that before a person using Ubuntu files a report they should update their BIOS. I guess I should have done that first. Again, new at this. Nov 9, 2012 at 2:49
  • @TempleOntherat - good find... if that does not help let me know. If you have IRC I can walk you through reporting a bug.
    – cprofitt
    Nov 9, 2012 at 3:58

I resolved my own issue by updating my BIOS. I did this by entering my model of Toshiba at http://www.csd.toshiba.com/cgi-bin/tais/support/ and downloading the latest BIOS. Be sure to read all documentation that comes with the download before updating. https://help.ubuntu.com/community/ReportingBugs says "Outdated and buggy BIOS firmware is a common cause of a variety of hardware issues (ex. intermittent wireless, suspend not working, and certain keys on keyboard not working correctly, kernel panics after plugging USB drive in)."


Worked for Toshiba Satellite L-750

open unity search and type "additional drivers" select: using NVIDIA binary driver -version .... apply changes and reboot


I have a similar problem and the workaround I found is to use the following command in a terminal:

echo 300 | sudo tee /sys/class/backlight/intel_backlight/brightness > /dev/null

Change the 300 to adjust the brightness level. It is not an ideal solution but at least it gives some control on screen brightness.

There's a bug report on launchpad. You may say that this bug affects you too if you wish.

  • the bug is for buttons that stop working after a suspend.
    – cprofitt
    Nov 7, 2012 at 14:34
  • Yes it's true, but I've seen a similar problem on another laptop (no brightness control at all) where the workaround works as well.
    – To Do
    Nov 7, 2012 at 14:40
  • this work around is the command line version of using system settings though; correct?
    – cprofitt
    Nov 7, 2012 at 15:14
  • …when neither system settings nor shortcut keys work.
    – To Do
    Nov 7, 2012 at 15:21
  • Did you try it? Did it work?
    – To Do
    Nov 7, 2012 at 15:21

If like me these solutions don't work for you then try programming the keys. First install xdotool:

sudo apt-get install xdotool

Then open Keyboard from System Settings (Applications->System Tools->System Settings in Gnome).

Go to the Shortcut tab add press "+" to add the following shortcut:

Name: Brightness Up
Command: xdotool key XF86MonBrightnessUp

Click "Apply" then click on "Disabled" next to the new "Brightness Up" entry. Now press the key that corresponds to brightness up - F3 for me, but possibly F7 or something else for you.

Click "+" again and repeat the above steps to add the following entry for brightness down:

Name: Brightness Down
Command: xdotool key XF86MonBrightnessDown

Now enjoy your brightness - or darkness if you are pressing the other key.


try this to fix it. turn off computer, then remove battery and unplug the computer if plugged in. Now press and hold down the power on/off bottom for 15secs. This should reset your default computer settings, you will not lose anything on your computer. Now put battery back on and plug in your computer. Turn your computer on, hope this helped!

Matt Dang NZ

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .