I am running xubuntu 12.10 on my msi wind U100 netbook. I have a problem with the wireless connection. Whether the wireless connects automatically to a known wifi hotspot (both at home and starbucks) is temperamental. Sometimes I need to reboot one or more times to get it connected. Otherwise, it tries and keep asking me to enter the password (which is saved and when it works it does, so the problem is not with the password).

Every time my computer awakes up from sleep the same problem. I have to do a reboot to connect to wireless.

I searched everywhere but found no solution. I would greatly appreciate if someone has any solution. I will gladly share the hardware/software or config info, if asked, but I don't know exactly what to share and where to find them.

Thanks you for any help.

  • I figured out upon further reading that the problem lies with my wireless adapter (realtek rtl8187se). As it happens r8187se (the default driver) is buggy. It keeps dropping the connection whenever it wants. Connecting to the network also takes random tries with disabling/enabling the wireless card (using the physical button), disabling/enabling wireless (from the network manager), and if nothing works, a reboot. – deehzee Nov 10 '12 at 10:42
  • I have ordered a Intel 4965AGN PCIe mini card adapter to replace my realtek one from my msi wind u100 netbook. It costs only $10 on amazon. I will post if that solves the issue. – deehzee Nov 10 '12 at 10:49


The problem seems to be with the buggy driver r8187se . The resolution is outlined below, with detailed steps and explanations to follow. Note that this problem could arise out of other buggy drivers as well, and may work. I am describing my situation with RTL8187SE on msi wind U100 netbook running ubuntu 12.10.

  1. Download the WinXP driver for the realtek wireless lan.
  2. Install ndiswrapper-1.58rc1 (not the default version ndiswrapper-1.57 from the repository. See more details below.
  3. Install the downloaded driver using ndiswrapper.
  4. Blacklist r8187se.
  5. Configure to load ndiswrapper.

STEP 1. Download the Windows driver for Realtek RTL8187SE wireless LAN

Download the suitable driver from Realtek. Unpack the zip file, navigate to the appropriate WinXP folder and locate the driver as *.inf file.

STEP 2. Install ndiswrapper-1.58rc1

The version found in the ubuntu repository of this driver is 1.57. There has been many problems reported using this version or compiling from ndiswrapper-dkms. That is why I am not suggesting the straight foward use of apt-get to install ndisgtk. It gives the error "driver not found." For the work around I followed and suggest the following method:

  1. Download ndiswrapper-1.58rc1 from this site.

  2. Extract

    $ tar -zxvf ndiswrapper-1.58rc1.tar.gz
  3. cd to the extracted directory. And type in the command line:

    $ make
    $ sudo make install

Now ndiswrapper is installed.

STEP 3. Install the Windows dirver in ndiswrapper.

Follow these steps:

$ ndiswrapper -i /full/path/to/WinXP/Driver/driver.inf
$ ndiswrapper -m
$ modprobe ndiswrapper

Now the Windows driver is ready to be used.

Now we need to disable r8187se from loading, and make ndiswrapper load automatically at startup and wake up from suspend.

STEP 4. Disable r8187se.

Edit the file /etc/modprobe.d/blacklist.conf (or, an appropriate file to this effect, if you are running an older version of ubuntu) as root and add the line:

blacklist r8187se

STEP 5. Enable ndiswrapper automatically.

Edit the file /etc/rc.local and add the following line before the last line:

modprobe ndiswrapper

Make sure this file ends with the line:

exit 0

Now there should be no problem. At least I didn't!

  • Any suggestion to improve this solution (in efficiency or execution) will be welcome, especially in Step #4 and #5. – deehzee Nov 12 '12 at 9:24
  • current version of ndiswrapper is 1.59 en.wikipedia.org/wiki/NDISwrapper should I use that? – Harry Moreno Oct 17 '14 at 8:37

Would you tried it before?

sudo gedit /etc/pm/config.d/config

This command will open a empty file,then add the following line into the file


I think,this operation will solve the problem that occurs when your pc is waking up.


  • The driver ubuntu uses for the card by default is r8187se not rtl8187se. The problem is not just after sleep, it happens whenever I disconnect the wifi, and then try to reconnect. After I changed the driver using ndiswrapper (version 1.58rc1, version 1.57 from repo will not install), it's now easier to connect right after a reboot. But the problem regarding reconnecting remains. – deehzee Nov 11 '12 at 19:47
  • I tried what you suggested (with rtl8187se replaced by ndiswrapper). After that my computer won't suspend. Clicking on suspend button only disconnect (and reconnect after a while) the wifi. – deehzee Nov 11 '12 at 20:08
  • Sorry, i didn't try this command.But some ubuntu users said that this operation is useful for the problem which occurs after sleep. You can take back this operation by delete the line you added from /etc/pm/config.d/config file. – Hckr Nov 11 '12 at 23:08
  • Thanks Hckr for your comments. I have a solution, and I am going to share ti later. Basically, the problem lies with the driver r8187se. The driver rtl8187se is in staging and has been moved. So I downloaded the WinXP driver for realtek RTL8187SE wireless lan, and loaded with ndiswrapper-1.58rc1. The problem is this driver isn't loaded automatically. And so whenever it comes out of sleep the old driver was being used. To remedy that I had to do two things: 1) Blacklist r8187se, 2) Load ndiswrapper using modprobe in /etc/rc.local. Now it works perfectly! – deehzee Nov 12 '12 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.