I've just upgraded from 12.04 to 12.10. For the most part, everything works fine, but I have a few small problems with Unity, or maybe Compiz.

When I hit the Super key, or click on the dash launcher, the dash sometimes comes up behind the other windows on the screen. As you can imagine, this makes it somewhat tricky to use.

Once it has started coming up behind, no amount of trying again will convince it to come back to the front.

Possibly related, the Alt-Tab switcher doesn't show either. It maybe that there isn't one, or maybe that's behind also? Alt-Tab does switch the windows, but there's no visual indicator.

When I hit Super-W, the windows do all do the zoom thing, but it's slow and juddery where it used to be smooth in 12.04.

I'm using the standard "radeon" driver, same as before, with a triple-head monitor setup (and that works fine). I've not tried the proprietary drivers as I've previously found the multi-monitor support much weaker than the default driver, but maybe that's the way to go now?

Video play fine. Even WebGL seems ok.

Do other see this problem? Is it a bug? Or have I just got some left-over config from 12.04 in the way?

2 Answers 2


TL;DR: disable and re-enable unity plugin in CCSM.


  • (optional) if you have compiz config setting manager then issue

    apt-get update && apt-get install compizconfig-settings-manager

  • Launch ccsm (either on command line or through dash)

  • Then use the search box and type "unity"

  • click on the plugin
  • on the left part you can uncheck box to disable unity
  • re-enable unity by re-checking the box.

Note: This answer was in a comment of the lengthy unrelated accepted answer.

Note2: This answer works for the current session but won't fix definitively the issue


I believe I have found an answer myself. I'm not sure exactly what solved it, so I'm going to list what I tried and didn't appear to work also.

First, I tried the fglrx driver. I installed this using the tab in "Software Sources". When I rebooted, the first thing I noticed was that the Ubuntu splash screen only came up on two of my three monitors. Then the login screen came up similarly on only two monitors. Interestingly, the montors were not "mirrored", as with the xserver-xorg-video-ati driver, but only one screen had the login prompt, and the others just Ubuntu logos.

Having logged in I tried all sorts of ways of configuring the display using both the Ubuntu display controls, and the ATI Catalyst Control Centre, but no amount of fiddling could get all three monitors working. It kept claiming that either the monitor wouldn't come on, or that there wasn't enough memory, despite the fact I've been using it triple-head for years.

On the plus side, the 3D effects did seem much snappier, and the Unity dash and HUD did come up on top. Some might consider this a fix, but I was still one monitor down.

Second, I tried the fglrx-updates driver, also selected in "Software Sources". I observed no apparent differences to the straight fglrx driver.

Finially, I restored the xserver-xorg-video-ati driver, and tried playing around with the Compiz Control Centre (actually, I'd tried this before, but failed to fix anything).

After much futzing with Compiz Plugins that didn't fix the problem, I eventually disabled the Unity Compiz Plugin. This made all the Unity UI elements vanish. For a while I thought I'd stitched myself up because none of the windows would respond, but then they came back to life, another application-switcher got enabled, although there was still no obvious way to launch new apps. I then re-enabled the Unity Plugin, and everything came back the way it had been, but with the Dash in front of the other windows where before it had been behind.

So far, fingers crossed, the problem has not recurred, so I'm considering it solved. :)

  • Tried to disable and re-enable unity plugin in compiz settings manager and it worked! I'm using opensource ATI drivers.
    – igorp1024
    Commented Nov 15, 2012 at 17:38
  • Bad news, after a few days the problem came back again. :( This time I also tried Alt-F2 and ran "unity --replace" and that seems to fix the problem also, but again, only temporarily.
    – ams
    Commented Nov 16, 2012 at 9:38
  • 1
    I mean disable and then re-enable it in CCSM (CompizConfig Settings Manager)
    – igorp1024
    Commented Nov 19, 2012 at 15:54
  • This has nothing to do with graphic drivers. I'm on nvidia and have same issue. @igorp1024 had the solution for me.
    – vaab
    Commented Apr 9, 2013 at 8:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .