I have installed Sublime Text 2. I have set all the default files to open with this. However, when I open a file from my server using FileZilla (by right-clicking and file and then click "View/Edit") it still opens up in Gedit.

Can I change this?

12 Answers 12

up vote 27 down vote accepted
+50

You can set it by going to edit > Settings, and then going to the Filetype Associations section and adding the filetypes and the editor you want.

  • here is an example to associate python files with sublime py "/path/to/sublime_text" – simple_human Feb 13 '14 at 8:31
  • 6
    html /opt/sublime_text/sublime_text ubuntu 14.04 – zipzit Jan 3 '15 at 6:51
  • This resolution is incomplete, without @mrcktz's answer – Santi Jun 19 at 6:40
  • Its an accepted answer but its totally incomplete. common files are always available in filetypes. there are some other confirgurations that are definitely missing in this answer. – user3491994 Oct 3 at 4:05

Go to Edit -> Settings and navigate to File Editing.

Choose Use custom editor and browse the executable file of Sublime Text 2.

Close the dialog by pressing OK.

Done!

Screen shot of a mac application enter image description here

  • Combination of this answer and answered by @Spice should be the best and accepted answer. – Santi Jun 19 at 6:38

as per direction given in set default editor for filezilla in ubuntu 16.04 , you can modify for default editor.

You have to change the preference as for the executable file exist in /usr/bin/$PATH for editor.

Write in the terminal : dpkg -L sublime-text to check the sublime current location.

And then try to find something like this : /usr/bin/subl

Now you just need to go to - edit - settings - Filetype Associations

And write the following :

html /usr/bin/subl

to open in the same window

and...

html /usr/bin/subl -open

to open in the new window :)

You can set it by going to edit -> Settings in filezilla, and then go to Filetype Associations section and add the filetypes and the editor you want for them.

html /opt/sublime_text/sublime_text

/opt/sublime_text/sublime_text is executable path of the sublime text editor. You can enter your own path of executable file.

All the above posts are correct, i am just sharing with pictures for better understanding and I am using ubuntu 16.04 with updated FileZilla.

Run this command. dpkg -L sublime-text step1

step2

Press CTRL + L and Search for /usr/bin sblm and select. step3

  • click 'view/edit' on a particular text file
  • choose 'Use custom editor'
  • click 'Browse'enter the location 'usr/bin'
  • select subl file

For Ubuntu 16.04. First, find out where your Sublime-Text is located: go to usr/bin and double click sublime-text. You should see something like:

#!/bin/bash

/opt/sublime_text_2/sublime_text --class=sublime-text-2 "$@"

Copy just the beginning of line 2:

/opt/sublime_text_2/sublime_text

Add html to the front:

html /opt/sublime_text_2/sublime_text

Go to edit -> Preferences -> Filetype associations and paste that in.

for me dpkg command didn't work. I manually had to find sublime-text installed folder and it was in snap folder of root. I pasted this line in custom Editor. please check if sublime_text is available in path or update it as per your sublime_text path. Rest settings as per image reference attached please.

./snap/sublime-text/18/opt/sublime_text/sublime_text

File-Editor Path Update FileZilla Image Reference

P.S : I'm on Ubuntu'18.

You can find directory your installation, in my case, the directory of install of sublime is:

snap/sublime-text-/24/opt/sublime_text/sublime_text

Case you have installed your FileZilla, can you open your old configure file, for it, you can use the commands:

vim ~/.config/filezilla/filezilla.xml

or

vim ~/.config/filezilla/filezilla.xml

in the file, you search the word "editor" using the command: /editor

look a picture

In line has the directory of your old text editor.

Here are steps to do it quickly -

Step 1: Open Filezilla > Then Click on Edit Menu. Under Edit Submenu Click on Settings ( As Shown in Screenshot Below)

enter image description here

Step 2: In Settings Window Click on "Use Custom Editor" Radio Button -> Then Click on Browse Button To Choose your Default Text Editor / Code Editor. ( As Shown in Screenshot Below )

enter image description here

Step 3: In Browse Window Navigate to Installation Directory of your TextEditor You wish to use. In my use I am using "Brackets" Text Editor So I navigated to "C:\Program Files (x86)\Brackets\Brackets.exe" that is installation directory of my text editor.

enter image description here

Step 4: Then Click on Ok Button to close Settings Wizard.

If your's Specific files like php files, cfm files, css files or js files still not opening in your default editor Then WAIT THERE IS ONE MORE Step you need to follow

enter image description here

Step 5 - In Settings Window that you opened in step 1 -> Click on FileTypeAssociations -> It will show list of all files extensions configured to open in specific text editor. See screenshot below -

enter image description here

You can see in above screenshot some of my filetypes are associated still with notedpad.exe. for example - i was trying to open .php file from ftp in my default text editor but its associated with notepad.exe that's why it was not opening.

In order to open php file in my default editor from FTP I changed below line

php C:\Windows\system32\NOTEPAD.EXE

to this line below -

php "C:\Program Files (x86)\Brackets\Brackets.exe"

I have done it for php you can do it for any other filetype you wish and also for any other texteditor you wish.

This is for those ubuntu user who installed sublime-text-editor by snap wanted to use in filezilla, they can use this command in "filetype associations".

php /snap/bin/subl

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.