So, I am trying to install skype through apt-get, but after running into this problem multiple times, and trying to find a solution, it still doesn't work...

I tried all the answers here: Installing Skype on 12.04 64 bit causes errors, but I still get the error. (my problem is exactly the same as that one, too) I even went and edited the package status thing manually, and removed all references to 'skype' or 'skype-bin'. I still get the problem... I'm running ubuntu 12.10, as a dual-boot with windows 7. It's a 64-bit computer.

4 Answers 4


I found the solution to this problem from a different post.

First a downgrade is required and done with the following:

create the 'preferences' file:

sudo vi /etc/apt/preferences

and insert the following lines:

Package: *       
Pin: release a=quantal*
Pin-Priority: 2012

enter :wq to write the file. Pin-Priority must be greater than 1000.

Then you may downgrade the offending applications with:

sudo apt-get dist-upgrade

That's it.

Now use sudo apt-get install skype

And it works!


You may find it a little easier now as Skype have released more Multiarch support to help 64bit users

Details and download instructions here:

OMGUBUNTU News re 64bitSkype

There is also a really good how to with Skype here for Ubuntu users on askubuntu

AskUbuntu How to sort Skype guide

Let us know how you get on.


Faced the same problem after installing beside Vista with Wubi.exe in ACER with dualcore. Same error message. Then and as had same problem with wine, I've tried the following:

Bootable pendrive with Ubuntu 12.10 amd64. Absolutely clean install retaining existing Vista installation. Reboot. Downloaded Skype multiarch for Ubuntu Took a little bit longer. It finished with no error messages. After rebooting again (for sure). It worked greatly. As usual. Done the same steps on my other 3 Dell Vostro. (clean install of ubuntu from USB). Same great results. And also wine was installed with no problems. Sure this is not solution for all, and even me does not understand the technical reason. But worked fine.


Here is s SOLUTION that you can follow to get it resolved. I came across this while installing skype, I solved it changing repository. See it here

Then run update using update manager. After that you can install skype...

    sudo apt-get install skype
  • Please include in your answer all the steps necessary for the solution to work.
    – landroni
    Mar 10, 2014 at 9:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .