41

I really love how Evince works but this little thing is annoying me so much. When I select a title or a subtitle from the table of contents it shifts the zoom. On windows it was just easy as pie with Foxit but its Linux version really needs time.

4
  • "When i select a title or a subtitle from the content menu it shifts the zoom". Can you clarify this? If you mean to say that the zoom level changes when choosing a different entry in the table of contents, that works perfectly fine for me. What exactly happens when you choose an entry? Nov 7 '12 at 0:45
  • 2
    yes i always want it to be set "fit page width" but when i select a title it changes that something like "%75" and i have to re-set it to "fit page width" everytime.Save the current option did not works so far.
    – c.k.
    Dec 4 '12 at 9:10
  • 2
    Yes yes thanks for asking this, just what I needed
    – Miguelgraz
    Oct 6 '17 at 10:14
  • gsettings set org.gnome.Evince.Default sizing-mode 'fit-page'
    – The Demz
    Nov 29 '17 at 3:46
44

this should work.

open up a terminal and type:

gsettings set org.gnome.Evince allow-links-change-zoom false 
5
  • No such key 'allow-links-change-zoom' . using 12.04, evince 3.4.0
    – Rashi
    May 7 '15 at 17:46
  • 5
    Thanks, this helped a lot! There is no way to set this behavior through the Evince UI. You can save the default settings, but clicking a bookmark link upsets the same, unless you set this from gsettings. Jun 4 '16 at 14:06
  • 3
    Exactly this, just set it from gsettings and be happy
    – Miguelgraz
    Oct 6 '17 at 10:14
  • that command worked for me on Fedora 32 workstation, thanks pal. "Document Viewer" (Evince) 3.36.7 Jul 26 '20 at 14:57
  • Worked for me in Pop OS 20.04. Super frustrating problem and this is the only fix I've found that works. Thanks!
    – Matt West
    Oct 1 '20 at 11:17
12

To set the default zoom, you can either set it in the program and then go to edit > 'save current settings as default' or select your value and run

gsettings set org.gnome.Evince.Default zoom 1.75

However, i think what you are really referring to is when, say you have a big zoom level of 175% and you have the sidebar enabled and continuous mode enabled, scrolling to the next page upsets the zoom. This makes the page go off centre and you have to adjust it manually each time, as the first screenshot below shows.

To change this behaviour, the only real fix is to select the 'fit page width' option by going to view > 'fit page width'. Then go to edit > 'save current settings as default'. This will eliminate the issue, as the second screenshot shows, although the zoom level will drop a bit as you can't set a zoom level and have the 'fit page width' option enabled.

enter image description here

enter image description here

6
  • The problem is i know about the feature "save the current settings as default" but when I select a title crom context it just changes the zoom again.
    – c.k.
    Nov 8 '12 at 1:50
  • 1
    @c.k. The 'fit page width' setting should be probably what you need.
    – user76204
    Nov 8 '12 at 1:57
  • 4
    I with with the OP. 'fit page width' + 'set current settings as default' does not resolve the issue. I've tried this combo at least a dozen times, the zoom level is still resetting whenever evince launches, and then (more annoyingly) every time a page is selected from the sidebar/table of contents. Jul 4 '14 at 17:21
  • Agreed, does not work.
    – Dodgie
    Dec 7 '14 at 22:24
  • 1
    See askubuntu.com/a/612913/207451 Jun 15 '16 at 15:54
3

Simple run $dconf-editor then org/gnome/evince or search via Ctrl+F after opening the editor. Then change the default settings default/continuous/zoom etc.

1
  • Thanks for suggestion on using dconf. On Ubuntu 18.04, set allow-link-change-zoom to Off helps me avoid this zoom-changing issue.
    – bizi
    Sep 14 '19 at 20:25
2

This issue seems to be related to dconf and Evince apparmor settings. A possible solution is buried at this link:

https://bugs.launchpad.net/ubuntu/+source/evince/+bug/682492

tl;dr

  1. First, install dconf-tools:

    apt-get install dconf-tools
    
  2. Then reconfigure apparmor:

    sudo dpkg-reconfigure apparmor
    
  3. Configuration will ask for the path to your home folder. Which is generally:

    /home
    

This helped me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.