I have my eclipse telling about every 10 minutes that "eclipse Could not save master table to file".

I found an old discusion on this, which tells to delete /home/<username>/.eclipse folder, but I did a search and there's no such folder in my whole system.

Any idea how to solve this?

  • If /home/<username>/.eclipse is doesn't exist they probably mean the folder where you have installed eclipse. I have found some other file that bugged me there. Aug 28, 2012 at 7:15

3 Answers 3


Try setting correct privileges to the file


I would suggest setting correct permissions for the whole workspace

See discussion here

  • It was solved with another eclipse version. I hadn't try your solution, but would probably work.. or not.. anyway.. :) Mar 1, 2011 at 18:35
  • Vadim your link doesn't work...
    – Kibi
    Apr 18, 2012 at 9:02
  • @Kibi, I've updated the link Apr 18, 2012 at 12:13
  • Thanks @VadimRutkovsky - unfortunately the link in the link doesn't work too well, ok, at least I have some place to search from
    – Kibi
    Apr 18, 2012 at 16:16

My .safetable file was missing, so I just created it and problem solved.

  • 3
    Can you explain where this file is, and how to create it.
    – Mateo
    Aug 14, 2012 at 1:28

it's clear from the path reported that .safetable is not a file, but a folder. I have just hit this issue and created the folder, in the hope that eclipse will create the file with its proper contents next time it tries. If I don't report back then you may assume this was all that was needed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .