Installed Ubuntu in my MacBook. It worked fine at first. Installed additional drivers and updated the restarted. Now, all I get is a command line. I can't boot back into the USB stick I originally used to install Ubuntu. Help?

  • When you say command line - has the system booted to the login prompt, but without a graphical interface? If so, login and try running sudo xinit. See if the GUI starts up or, if not, post what the error was. As for the USB stick - try re-installing the image or test it on another machine to check whether it's the USB or MacBook at fault. – jackweirdy Nov 6 '12 at 15:58
  • yes! I get a log in minus any sort of GUI. I log in and I can use commands. when I try xinit I get "FATAL: module nvidia_current not found. then a fatal server error. – chasemassey Nov 6 '12 at 16:06
  • OK - so that's because when the additional drivers were installed (these drivers being the proprietary nvidia drivers) something went wrong and now X cant find them. I'm going to retag the question so someone with more experience can help out :) – jackweirdy Nov 6 '12 at 16:10
  • Awesome, thanks. I still can't boot from my USB stick but I can connect to the internet from a wired connection. – chasemassey Nov 6 '12 at 16:17
  • I had a problem a while ago when I installed from USB where the installer put Ubuntu on my hard drive but GRUB (the bootloader) on the USB stick. This meant that my PC wouldn't boot (at all) and that whenever I plugged the USB in I couldn't get back to the installer because it had been written over. You could be experiencing the same; there's an open bug here bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/46520 – jackweirdy Nov 6 '12 at 16:22

I had a similar problem after choosing the nvidia_current driver. I had my background picture displayed after logging in, but nothing else except for an error message.

In my case, it turned out that the nvidia_current driver had been blacklisted, so it was not loading correctly. To check if that's your problem, run the following:

grep nvidia_current /etc/modules /etc/modprobe.d/*

I had a file called blacklist-local.conf containing the line blacklist nvidia_current. Since that was the only line in the file, I used sudo to remove it, and everything worked.

I've raised bug #1083998 to complain that the Additional Drivers utility didn't spot the blacklist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.