1

My problem is that my desktop is empty -- there are no files or directories in it. The launcher on the left and the menu at the top are both ok. But, after a recent upgrade from 12.04 to 12.10, everything in my Desktop was emptied.

I do have files in my ~/Desktop directory, which is what I want displayed. In ~/.config/user-dirs.dirs, I also have XDG_DESKTOP_DIR="$HOME/Desktop/". Is there something else I should be looking for?

I actually have another Ubuntu machine and I don't have the same problem there after upgrading. So, I don't think this is a bug with 12.10 but just some setting (a package, etc.) that was set in one machine but not the other.

Oh, I am not sure if this is related to nautilus, but the two machines have the same nautilus-related packages installed...

Any help would be appreciated!

1 Answer 1

1

Maybe for some reasons Nautilus is configured not to display icons on your desktop.

Open a Terminal an run

gsettings set org.gnome.desktop.background show-desktop-icons true

to tell Nautilus to display them.

3
  • That did it! Thank you! I even did a reboot (ok, logging out would probably have been enough) to make sure the setting stayed and it did! I'm fairly sure that no amount of Googling would have helped me find this setting -- thanks a lot for your help!
    – Ray
    Nov 6, 2012 at 5:00
  • how to get a terminal on empty desktop?
    – user156614
    May 8, 2013 at 0:22
  • Maybe Ctrl+Alt+T works May 8, 2013 at 1:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .