I have recently killed xserver on my machine after a regular update. I have uninstalled and reinstalled


with no success. Looks I have reinstall xserver. How do i achieve this?

Please and thank you.


Method : 1

One easy way to reinstall the X server is to:

Restart the PC with the live ubuntu disk.   
Choose safe graphics mode.  
Open a terminal  
cd to /etc/X11  
cp xorg.conf to /media/usbdrive  
open gftp  
upload the xorg.conf file to a server  
restart PC without the live disk  
cd /etc/X11  
sudo rm xorg.conf  
then wget www.yourserver/xorg.conf  

You will be able to start X without a hitch because the live cd in safe graphics mode automatically determined your X settings.

Method : 2

If you just need working configuration, not the whole Xserver? then, backup your /etc/X11/xorg.conf and do

sudo dpkg-reconfigure xserver-xorg

Method : 3

If you really need to reinstall whole Xserver, try

sudo apt-get install --reinstall xserver-xorg


  • I tried all of these it still doesn't want to bring back my xserver still booting in tty mode – myusuf3 Jan 14 '11 at 0:16
  • just try Ctrl+Alt+7.. or Ctrl+Alt+Backspace – Sen Jan 14 '11 at 5:53
  • "Unable to locate package xserver-org" – Cerin Jan 3 '15 at 5:30

it turns out there was some issue with my nvidia-current running the following command managed to get me back to non-accelerated gui, where I was then able to reinstall nvidia-current through the gui.

From the terminal:

sudo apt-get remove --purge nvidia-*

Then reinstalled nvidia driver through Ubuntu setup.

  • that's the real issue, other answers just getting the problem even worse. – shahar_m Jul 1 '18 at 13:41

This actually worked for me.

sudo ubuntu-drivers autoinstall

Some of my nvidia drivers were not up to date. I didn't know there were more than one nvidia driver to update.

  • 1
    This worked for me Thank ! xfce4 and gnome on xorg did not work. I added sudo apt install xorg xauth ubuntu-desktop xfce4 – Tinmarino Mar 30 '19 at 18:06
sudo apt-get install --reinstall xserver-xorg 

made the wallpaper and mouse visible. But to see everything else I had to use

sudo service gdm restart

this made me reach the log-in page. If it happened that the machine didn't recognize your password, make sure /tmp is writable by everyone. It should also have the sticky bit (leading 1 in octal)

sudo chmod 1777 /tmp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.