I'm trying to setup a dual boot system with Windows Vista 64 (already installed) and Ubuntu 10.10. I added a new drive which is identical to the one Vista is installed on. When I boot into the LiveCD I can see and mount the second drive and edit it in Gparted. However, when I use the installer it will only bring up the drive that already has Vista installed.

I've tried everything I know. I'm not sure if its a BIOS setting or something else I've missed.

I've also tried both the desktop and alternate amd64 installs with the same result.

  • Did you choose manual partitioning?
    – psusi
    Jan 12, 2011 at 20:39
  • Yes, it is in manual partitioning where I do not see it. Also get the same results in the other two install options.
    – atodd
    Jan 12, 2011 at 21:07

6 Answers 6


Try to boot a live session and start a terminal session (or to switch to the console with CTRL-ALT-F1) and issue:

sudo os-prober

You'll probably see a probing error which could be the reason why your drive is not taken in consideration. It's quite likely that your second drive has leftovers of a RAID configuration, in this case it's sufficient to do:

sudo dmraid -rE

(-r = raid, -E remove metadata) and confirm the operation. Start the installer and you should see it.


sudo apt-get remove dmraid

This seems to have fixed the problem for me. At least now I'm not getting the empty drive box. It's asking me to choose from 3 options.

  • check with

    cat /proc/partitions

to see which partition is the new one (the size can give you a clue)

  • Create some dir to mount the disk

  • Add a line in /etc/fstab accordingly


 sudo mount -a

Have you tried using the alternative installer iso? It is a hassle to use, but gives you much more control over the installation process.

This is just a hunch, I am not sure it will solve the problem. It requires an additional CD-sized download and about half an hour of answering prompts about things the graphical installer discovers automatically, so only try it if the easier methods have failed.


I ran into a somewhat-similar installation issue when I was attempting to install Kubuntu 10.4 on a computer with Windows 7 installed. With the issue, I only had one hard drive, but it just wasn't showing in the partition list, even after I partitioned a good chunk off for the install.

The eventual solution revolved around the fact that the live cd had dmraid installed by default.

I live-booted into terminal, entered sudo apt-get remove dmraid and my issue was fixed. Hope it works for you as well.


I had this issue when I had a partition type of GPD (had Windows 10 on the drive prior), to get around this I used fdisk to create a new 'dos' label.

In this day and age I'm amazed that the install doesn't account for this (and support GPD)

Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .