Everything seemed to install fine. I can start google earth and all layers are available, I can even zoom in and look at 3-D buildings. But there is absolutely no image data displayed at all. If you look at the whole globe the outlines are there on an invisible globe. As you zoom in the base looks dark grey almost black but there is no image. I have tried:

Tools > Options > Graphics > Safe Mode
Tools > Options > Texture colors > all combinations
Tools > Options > Cache (tried several changes to the numbers)

lspci shows

Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)    

Running on a Dell Inspiron 6000 laptop (1.5Gb memory)

  • What video drivers are you using and which is your graphics board?
    – Ivan
    Nov 5, 2012 at 14:02
  • updated re: @Ivan's question.
    – Dennis
    Nov 5, 2012 at 14:20
  • No answer there, but jut to confirm the bug, I have the same problem with different settings. Installed Google Earth 7 on 12.10, my machine is an Asus EeePC 1000. Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03) When I launch GE from the command line, it doesn't show any error. I also tried the different texture settings, but no luck. Funnily enough, streetview does work.
    – user106071
    Nov 6, 2012 at 23:00
  • same problem here, using a Nvidia Geforce GTX 650 Ti Boost and Ubuntu 13.10. Nov 9, 2013 at 9:30
  • Google Earth does not want to install in Ubuntu 14.04 and complains "Dependency is not satisfiable: ia32-libs" so I think Google has dropped the ball on this one. May 7, 2014 at 17:05


You must log in to answer this question.

Browse other questions tagged .