I'm having some issues when connecting to my house's wifi from my Ubuntu 10.10 laptop.

If the connection doesn't exists, when selecting the network (and after entering the WPA2 password) I'm able to connect. Once the connection is saved, when trying to reconnect, Network Manager works for a minute or so and then fails; the only way to reconnect then is to delete the saved connection and re-select the network from the list of available wireless networks. The same network works with no issues on the same laptop when running Win7, and on other wireless networks when running Ubuntu.

Is there a Network Manager log which I can take a look at for troubleshooting the issue? Are there any tools for checking the wifi status?

2 Answers 2


You can look at System --> Administrator --> Log File Viewer, Under "dmseg" file to see if something with the authentication process is wrong

window showing syslog

Some more experienced people will suggest to harvest the power of terminal by doing something like :

cat /var/log/* | grep network-manager > network-manager-output.txt

I hope you can find a solution to your problem


I have the same problem, very annoying. I tried disabling the 11n with options iwlagn 11n_disable=1 11n_disable50=1, but didn't help much.

My latest attempt (an hour ago) is removing network-manager and installing wicd. It's too soon to tell if it works, but so far no problem.

sudo aptitude -d install wicd
sudo aptitude remove network-manager
sudo aptitude install wicd

Edit: What finally worked was this

sudo aptitude remove network-manager network-manager-gnome wicd wicd-gtk

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .