14

Problem Loading Thumb Previews:

enter image description here

This started to happen after upgraded Ubuntu from 12.04 to 12.10.

21

This may happen if you get a different UID from the one you had before (this will remove you the ownership of those files). Try executing this on a terminal:

sudo chown -R $USER:$USER ~/.thumbnails

From 12.10 onward, thumbnais are also stored in ~/.cache/thumbnails, so you may repeat the same process for this location.

If none of those solves your issue, you can always remove them (they are automatically generated, and I think failed thumbs generations are cached):

sudo rm -rf ~/.thumbnails/* ~/.cache/thumbnails/*

Note: it's not the case of OP, but if you don't get previews to video files (ex: mkv, mp4) probably you are missing the video codec. This can be easily fixed by open the video with "Movie Player": it will propose a suitable codec.

  • How can I Find My Exact username? :( – Vishnu Bathala Nov 4 '12 at 17:44
  • praneeth@praneeth-HP-Pavilion-dv7-Notebook-PC:~$ sudo chown -R praneeth:praneeth ~/.thumbnails [sudo] password for praneeth: chown: cannot access `/home/praneeth/.thumbnails': No such file or directory @salem Thanks For Reply :D – Vishnu Bathala Nov 4 '12 at 17:46
  • ok, try creating the folder is missing: mkdir ~/.thumbnails, then logout/login. – Salem Nov 4 '12 at 17:50
  • i did :( but no change not worked :( – Vishnu Bathala Nov 4 '12 at 18:04
17

try changing nautilus preferences

Edit-> Preferences-> Preview-> Other Previewable Files-> only files under (set a higher MB value and then try reloading)

  • 2
    The standard limit seems to be at 10MB, which is quite low for modern DSLR cameras. – hitzg Nov 16 '15 at 13:40
8

I had the same issue.

I solved it by moving the .thumbnails folder and setting a symbolic link to .cache/thumbnails instead.

mv ~/.thumbnails ~/thumbnails
ln -s ~/.cache/thumbnails ~/.thumbnails

Is it possible that there were some changes?

It looks to me like the thumbnailers create their thumbnails in .cache/thumbnails, while nautilus keeps looking in .thumbnails.

  • 1
    Cheers Uh Rock Bro..!! It`s Working Thanks A Lotsss :)) – Vishnu Bathala Nov 10 '12 at 9:45
  • 1
    I had to create ~/.thumbnails, I also did your link trick. Hit refresh and nautilus started showing thumbnails, THANKS – DAG Oct 7 '16 at 1:58
6

Looks like the path has changed in recent versions. For me the issue in 13.04 was that ~/.cache/thumbnails was owned by root.

So for 13.04 at least, the command is:

sudo chown -R yourusername:yourusername ~/.cache/thumbnails

So Salem did have it-

2

If you are trying to access a network device like a NAS, then go to nautilus preferences, and choose Edit-> Preferences-> Preview-> Other Previewable Files->Show thumbnails->Always

Hope this helps!

1

there may be another factor causing this - perhaps you didn't install the right codec as suggested here: http://iwillfolo.blogspot.co.il/2013/10/thumbnail-doesnt-load.html

try installing ubuntu restricted extras. Open a terminmal and type:

sudo apt-get install ubuntu-restricted-extras -y
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Eric Carvalho Oct 2 '13 at 22:56
1

Depends on version of glib, the change was in the Gio module starting in the 2.35 series.

The thumbnail cache directory is prefixed with $XDG_CACHE_DIR/ and the leading dot removed (since $XDG_CACHE_DIR is normally $HOME/.cache). The glib ChangeLog indicates the path for large sizes was "fixed" (Added $XDG_CACHE_DIR)

starting with 2.35.3 so as to match the path for normal sizes, implying some versions using the added prefix, pior to 2.35.3 (I did not find any) are broke. The solution to add the symbolic link would provide a work-around for these broken versions.

1

In my case it was pretty simple: All I had to do is to change the preference in nautilus, by switching from "show thumbnails: only local files" to "show thumbnails: always" (my JPGs located in my smartphone weren't being shown). I found the issue thanks to Aswn, practically, so thumbs up for him/her.

1

Change nautilus preferences in

Edit -> Preferences -> Preview -> Files -> Show Thumbnails

from "Local files Only" to "Always". This could be helpful for usb memories or any external source like phones.

(ubuntu 14.04 LTS)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.