I'm running Ubuntu 12.10, Upon opening any shell I get the following error:

/home/jack/.rbenv/libexec/rbenv-init: line 87: cannot create temp file for here-document: Read-only file system

I realised this wasn't simply a rbenv issue, as any file I try to write to returns an error saying the system is Read-only.

I don't know how else to describe my problem, each time I boot up the system goes through a disk check, where it supposedly fixes several errors in my disk.

Here is my /etc/fstab

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=1cc4b2ab-a984-4516-ac25-6d64f5050244 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=4e0dfeae-701a-43ce-b5c6-65f15ab3d8e3 none            swap    sw              0       0

The entire file system is read-only. I've tried the following

sudo fsck.ext4 -f /dev/sda1

which gave the following (shortened) output

/dev/sda1: ***** FILE SYSTEM WAS MODIFIED *****
/dev/sda1: ***** REBOOT LINUX *****
/dev/sda1: 1257080/45268992 files (1.0% non-contiguous), 50696803/181051904 blocks

4 Answers 4


I have same problem with Xubuntu 12.10. The FS suddenly and randomly become read-only. Maybe it is related to this bug:


It seems like the problem is with new kernel.


Had this happen on mine and seem to have it sorted, at least for the moment. Boot from an older kernel in grub, then do the update to the newest version of xubuntu again. After that, immediately restart. When grub comes around again, boot in recovery mode for the latest kernel. Choose fsck. It'll come up with a message saying it has to change the file system to read/write to continue (or something along those lines). Select yes, let it do the check, and restart. Boot up normally and it should work, did for me anyway.

One thing I should note here, don't try to just go straight to recovery without booting/updating the older kernel first. I tried that originally and it still gives you the prompt about switching to read/write but then it just refuses to run the check and crashes.

  • Scratch that, fixed it for about a day. Problem is intermittent instead of constant since I tried it, so some improvement but still not a true fix...
    – user108135
    Nov 14, 2012 at 22:46

I had suspected this was a problem to do with my hard drive so I:

  • purchased and installed a new hard drive of the same specifications and
  • reinstalled Ubuntu 12.04 on it.

I have been running it with the new hard drive and am yet to encounter any issues.


I've rebooted and worked again. The problem first appeared when update manager was performing an update. Suddenly it has not been able to write to disk.

I've rebooted and tried to load an old kernel, it complained about non-readable File System. I've pressed fix option but failed too, then I rebooted and loaded later kernel (3.5.0-18-generic) and now it works.

I want to point out that this Ubuntu 12.10 amd64 version is not working as I expected, it suffers a lot of crashes and I had to boot 2 times with an usb drive to reconfigure everything as it was not able to mount the File System.

To solve that I booted using a usb drive and in a terminal and executed:

sudo dpkg-reconfigure -a 

To reconfigure everything. After that booted again the 12.10 in disk (not the usb drive) and reconfigured everything again as gnome-shell was not working properly.

So I executed again:

sudo dpkg-reconfigure -a

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.