My workstation has two Geforce 7300GTs and three monitors, and I'd like to put them to good use. Dual monitors works out of the box, but triple doesn't. How can I get the third monitor up and going when the Monitor Prefs dialog only shows two?

  • good question :) – RolandiXor Jan 11 '11 at 23:26
  • It is a good question, the most I have ever had is two, I too would be interested on a method to do this... – TheXed Jan 11 '11 at 23:34
  • Having same issue with dual Nvidia GeForce 210s and 3 monitors. Worked sporadically under 10.04, but can't get it to work under 10.10. Any Xorg experts out there ? Updated to latest Nvidia 260.19.29 driver, but still no joy... – angruth Jan 12 '11 at 12:40
  • I wonder if you can share the configuration here...I'm having a trouble with mine though my set up will be as follows: Video card is an ATI x5450 (dual head) -- 2 monitors Internal graphics (from motherboard) -- 1 monitor I'm thankful for any help. Anthony – user113208 Dec 7 '12 at 6:04

I think that you should be able to do that with installing official nvidia drivers and running nvidia-config

sudo nvidia-config
  • 1
    I think TwinView only works on one video card, and for only two monitors? – jldugger Jan 12 '11 at 5:07
  • 1
    Actually, that worked out okay, once I figured out my third monitor had crashed internally and the video card was fine. – jldugger Jan 13 '11 at 2:38
  • 3
    For posterity, I set each monitor up as seperate X screens and checked "enable xinerama" and it works as three monitors on a single desktop pretty painlessly. – jldugger Jan 13 '11 at 2:39
  • I tried NVIDIA X Server Config GUI in 14.04 but no luck with setting three monitors. It seems to only support two displays at the same time, while the internal monitor of my laptop doesn't work. It works normally on Windows. I use GTX980M – xji Dec 6 '15 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.