I'm trying to run an apt-get upgrade (after first running apt-get update), but my Ubuntu 12.04 server isn't completeing the upgrade process. It asks me if I want to upgrade 6 available packages, then it says it's reading the logs, and then I believe nano opens and shows the following:

Get:1 Changelog for base-files (http://changelogs.ubuntu.com/changelogs/pool/main/b/base-files/base-files_6.5ubuntu6.4/changelog) [78.4 kB] base-files (6.5ubuntu6.4) precise; urgency=low

  • Mark /etc/os-release as a conffile, and migrate it in the preinst for the benefit of people who tested the previous precise version

    -- Adam Conrad Tue, 23 Oct 2012 22:52:07 +0100

base-files (6.5ubuntu6.3) precise-proposed; urgency=low

  • Install /etc/os-release. LP: #947236.

    -- Matthias Klose Tue, 09 Oct 2012 19:36:33 +0200

Get:1 Changelog for libudev0 (http://changelogs.ubuntu.com/changelogs/pool/main/u/udev/udev_175-0ubuntu9.2/changelog) [156 kB] udev (175-0ubuntu9.2) precise-proposed; urgency=low

  • Add persistent-input-symlinks-iface00.patch: Fix persistent input symlinks for interface 00. Thanks to a7x for pointing this out! (LP: #1057824)

    -- Martin Pitt Thu, 11 Oct 2012 09:17:05 +0200

/tmp/tmpU6dn1w (END)

I can only exit out of that using control-c, and once I'm back where I can enter commands I can type text but nothing shows on the screen. The commands work, I just can't see anything. Once I end the SSH connection and then re-connect it shows I have those same 6 packages available.

The 6 packages it shows that are available are:

base-files 6.5ubuntu6.4
libgudev-1.0-0 1:175-0ubuntu9.2
libgudev-1.0-0:i386 1:175-0ubuntu9.2
libudev0 175-0ubuntu9.2
libudev0:i386 175-0ubuntu9.2
udev 175-0ubuntu9.2

Any ideas on why the upgrade isn't working properly?

  • Try sudo apt-get update sudo apt-get dist-upgrade . To see the difference between apt-get upgrade & apt-get dist-upgrade see the manual man apt-get .
    – NickTux
    Commented Nov 3, 2012 at 14:28
  • @NikTh - Hey Nik, I tried that, but I'm running into the same issue as when I run sudo apt-get upgrade. Commented Nov 3, 2012 at 21:08
  • Figured this one out. I had recently installed apticron on my server so I could see when and what updates where available. I removed that and tried to upgrade but still ran into the same issue. It turns out apticron installs apt-listchanges which was the problem. Once I removed apt-listchanges everything updated successfully. Guess I'll need to run without apticron for now until I can figure out how to disable apt-listchanges from when I run an upgrade. Commented Nov 3, 2012 at 21:40
  • have you tried apt-get clean and apt-get autoclean before. You couold also try to remove the packages that responsible for the error retry thw upgrade and reinstall them again.
    – Josh
    Commented Jun 18, 2013 at 9:13

3 Answers 3


Kris, thanks for following up with yourself. Ran into the same issue.

To make it simple, for anyone with this exact issue, run in terminal:

sudo apt-get remove apt-listchanges

Looks like this post is getting updated, so I though I'd let you guys know what I did to get things working properly.

I like using Apticron on certain machines to ensure they're up to date, and I also like listchanges so I can see what changed and what the priority is. As Sylwester pointed out, you can enter "q" to clear the change log and continue with the update, but I went a step further.

I edited my /etc/apt/listchanges.conf file and edited my frontend variable. I set it to:


In doing so, when running an upgrade, the changes are listed in text but you're not asked to verify the change logs before applying the updates.


When presented with the list of changes you can press q to continue or, as you have noticed, CTRL+c to cancel ongoing upgrade. To fix your terminal in any circumstances you run reset which clears the screen and fix your terminal even when you have displayed binary data.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .