7

I'm using Ubuntu 12.10 with Gnome 3.6 on a brand-new Samsung NP900X4C.

The installer detected the wireless adapter, took in the SSID and WPA passphrase, wrote these into /etc/network/interfaces and connected perfectly.

Once installation was finished I wanted to switch to using NetworkManager to manage the wireless adapter, since this is much more convenient than fiddling with /etc/network/interfaces every time I find a new hotspot.

Therefore I edited /etc/NetworkManager/NetworkManager.conf to set:

[ifupdown]
managed=true

When I rebooted NetworkManager, the problems started: - The NetworkManager tray applet changed from saying device not managed to device not ready - I lost all internet connectivity as wlan0 would not associate to the Access Point - if I set managed=false in NetworkManager.conf and restarted both NetworkManager and networking services from the command-line, the Gnome desktop "semi-crashed" and lost all its Window Decorations, the panel, the launcher and basically became unusable.

However if I restart the computer completely after setting managed=false, wlan0 once again works perfectly.

1
  • 1
    In managed=false mode, wlan0 works after reboot because ifup configures it at boot time (if /e/n/i contains auto wlan0). In managed=true mode, ifup doesn't bring interfaces up automatically; but then NetworkManager should do so. I don't know why it said device not ready.
    – jdthood
    Mar 20 '13 at 9:34
6

I ended up fixing this myself, see the exact steps below.

Note that there may be an easier solution but these steps definitely worked.

  1. Make sure network-manager is the latest version (I have 0.9.6.0-0ubuntu7 ). You can check this with: sudo dpkg -l | grep network-manager

  2. Right-click on Network Manager tray icon -> Edit Connections -> Wireless -> Add Manually add the parameters for connecting to your WLAN.

  3. Edit /etc/NetworkManager/NetworkManager.conf to set... [ifupdown] managed=true

    DO NOT restart network-manager service.

  4. Edit /etc/network/interfaces to deactivate the auto-start of your Wireless interface (probably called wlan0).
    For example:

    From this: auto wlan0 .... to this: #auto wlan0

  5. Run /etc/init.d/network-manager force-reload

5
  • 1
    Interesting. Commenting out auto wlan0 should cause NetworkManager not to consider the interface an "autoconnect" interface. Yet you say that NetworkManager does bring it up automatically. Sounds like a bug.
    – jdthood
    Mar 20 '13 at 9:37
  • Did you by any chance also define the wireless connection using the NM Connection Editor?
    – jdthood
    Mar 20 '13 at 9:43
  • Guy, you are my savior: managed=true was exactly what I was sought for. My NM refuses to manage all a network connections, and I recalled that it was needed to turn it on in some config, but couldn't remember where.
    – Hi-Angel
    Sep 6 '14 at 15:53
  • This doesn't work for me on Ubuntu 14.04. Boot still takes forever with the message "Waiting for network configuration" and afterwards Network Manager and my wifi is still disabled. Nothing works until I manually run nmcli nm wifi on.
    – Cerin
    Jul 25 '15 at 22:12
  • @jdthood I guess it is rather an issue with poor NetworkManager documentation by Debian. Oct 8 '17 at 18:03
2

Uninstall wicd if you intalled it along with network-manager

If both are installed at a time, then there will be a conflict and only one will be able to use the device at a time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.