I have installed Xubuntu 12.04 in an 60 GB USB 2.0 external HDD. I have been using that rather than my desktop.

Recently I found myself in a fairly remote part of a third world country, with a very unreliable internet connections, a few laptops -- none of which boots off a USB. I did not expect that; it made things very difficult for me because I rely a lot on what I have in the xubuntu in my HD.

Upon my return I have been looking for a solution to the problem of booting my HD when there is no BIOS support for USBs. I ran into plop. I copied the plop boot manager to a CD but it did not recognize my external HD.

I also tried plopkexec. plopkexec recognizes my flashdrive containing Knoppix and can boot that up. But it does not recognize the ext HD containing the Xubuntu.

I am not much of a tech head. Can someone please explain why plopkexec cannot detect my ext HD, but can detect and boot the Knoppix rescue system in the USB flash drive?

Does anyone know of an alternative to plopkexec that I can use to boot the external HD?

I am under the impression that Linux boot disks and/or rescue disks should be able to boot my external USB HD regardless of BIOS support. Can someone recommend any that can actually do it. Despite much googling, I haven't found any that actually highlights the feature.


I also tried plop and plopkexec to boot Ubuntu 12.04 installed on ext4 filesystem on USB3 disk Ubuntu boots from disk on USB2 port but the disk is not listed when connected to USB3 port. The disk has also ntfs partitions. This is why I tried plop Not sure why plop doesn't boot from USB3 disk When using plpopkexec "View Log" indicates USB3 disk is found and partitions are listed but plopkexec log indicates the mount fails on all partitions. I guess it is because FS supported by plopkexec (version 0.3) are only ext2, ext3 and vfat (according to source). There is no such partiton on my disk

Hope this can help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.