6

I have a Dell Inspiron 17r, after a fresh install of 12.10, the subwoofer seems to be not utilized. No sound comes from it and in the Sound Control Panel the settings appear grayed out (see screenshot). How can I activate the subwoofer?

no subwoofer

I tried adding the line

options snd-hda-intel model=dell

in the file /etc/modprobe.d/alsa-base.conf and

enable-lfe-remixing = yes
default-sample-channels = 3

in the file /etc/pulse/daemon.conf, but still doesn't work.

EDIT: related question: Subwoofer doesn't work on Dell Inspiron 17R after upgrade to 13.10

2

On this answer: https://askubuntu.com/a/481831/307523, I found this comment I wrote last year: March 5, 2017 - Just to confirm this activates the sub-woofer for the Dell Inspiron 17R 7720 SE in Ubuntu 16.04.

Firstly you will need to install alsa-tools & alsa-tools-gui from either the software center or from terminal.

sudo apt-get install alsa-tools alsa-tools-gui

Open HDAJackRetask

Select the IDT 92HD91BXX codec

Check the “Show unconnected pins” box (the internal speakers do not show as connected)

  1. Remap 0x0d (Internal Speaker, which is your Front side) to Internal speaker.
  2. Remap 0×10 (“Not connected”, which is the subwoofer) to “Internal speaker (LFE)”

Select “Install boot override” to save the settings to apply at boot time. Reboot. When it comes back, you should have full sound from all speakers.


Note: Option 2. was removed due to new testing by alfC. It used to say:

  1. Remap 0x0f (“Not connected”, which is the under-display speakers) to “Internal speaker”
  • Excellent, the linked answer works. For some reason I have to also choose Settings -> Sound -> Simultaneous output to Built-in Audio Analog Surround 4.0 . – alfC Mar 24 '18 at 3:09
  • Also, one has to do only "0x0d -> override -> Internal Speaker" and "0x10-> override -> Internal Speaker (LFE)", otherwise the Left and Right channel come out from the right. – alfC Apr 1 '18 at 22:58
  • @alfC Thank you for your valuable comments. I've updated the answer to reflect. – WinEunuuchs2Unix Apr 1 '18 at 23:08
  • by all means, test it also. My laptop is 17R-5720 (not 7720) so the millage may vary. – alfC Apr 2 '18 at 0:04
  • @alfC I've moved off the 17R-7720 SE (Special Edition) and am now on a Dell Alienware 17R3 which also has a sub-woofer that probably doesn't work on Linux out of the box. I use Sony TV with 100-watt sub-woofer wireless attachment so haven't unteethered the laptop yet to find out if that subwoofer isn't working. – WinEunuuchs2Unix Apr 2 '18 at 0:08
2

I'm not sure this completely answers the question, but maybe it gets 90% there...

First, edit the following file:

sudo gedit /etc/pulse/daemon.conf

Uncommment and change the values of these lines:

enable-lfe-remixing = yes
default-sample-channels = 3
default-channel-map = front-left,front-right,lfe

Second, edit the following file:

sudo gedit /etc/pulse/default.pa

Add the following line to the end:

load-module module-combine channels=3 channel_map=front-left,front-right,lfe

At this point, I hear noise from the Subwoofer in the Test Sound option under the volume control. I can't tell that it comes from the subwoofer though. Maybe this is the way it is supposed to work.

  • this exactly the changes that I made before (see comments in adams answer) +1. As you say this is 90% there, the subwoofer now works although with some "chirp" sound (looks digital, not saturation). The bigger annoyance is that when earplugs are connected the subwoofer sound still goes externally. Do you know how to block the subwoofer from producing sound while earplugs are connected? – alfC Nov 28 '12 at 18:32
  • Try with the line options snd-hda-intel model=ref in alsa-base.conf, this will make the static sound (and actual music) come out from the subwoofer speaker. The problem with blocking the subwoofer when headphones are connected is a standing problem. – alfC Nov 30 '12 at 20:57
  • Thank you! Adding these edits got the Beats Audio subwoofer working on my HP Envy 17 1090ca! – Jeremy Jan 19 '13 at 20:25
  • Just a quick comment, use gksudo, not sudo. – Sablefoste Oct 28 '15 at 22:43
2
+50

Try options snd-hda-intel model=ref in /etc/modprobe.d/alsa-base.conf.

Control for subwoofer doesn't work in sound settings but sound can be heard.

  • 1
    In what file? what is ref? – alfC Nov 13 '12 at 23:39
  • I tried the change and it doesn't change any setting in the Sound Settings window options. Also, I wouldn't know how to force to play sound with the SB since there is still no Test option. – alfC Nov 23 '12 at 21:09
  • Based on this post I made some changes until one worked. It is difficult to tell what made it work but basically works now. The changes I remember doing are: in alsa-base.conf, the lines: #options snd-hda-intel model=alc269-dmic\\ options snd-hda-intel model=ref in default.pa the line: load-module module-combine channels=3 channel_map=front-left,front-right,lfe in daemoon.conf, the lines: ; enable-remixing = yes\\ enable-lfe-remixing = yes\\ default-sample-channels = 3\\ default-channel-map = front-left,front-right,lfe I'll accept this answer until figure out the exact changes. – alfC Nov 23 '12 at 21:40
  • Another problem I am finding with the current configuration is that when the earplugs are connected the subwoofer still can be heard externally. – alfC Nov 24 '12 at 9:16
  • This answer technically solves the problem. The problem with blocking the subwoofer when headphones are connected is a standing problem. – alfC Nov 30 '12 at 20:54
1

Ok I seem to have found a working fix for it with headphones enabled in my elemntary OS luna [ with lts-raring HWE for precise]

In /etc/modprobe.d/alsa-base.conf , add :

options snd-hda-intel model=ref

now you can enable sub-woofer with command :

amixer set 'Mono Mux' DAC1

but headphone jack sensing doesnt work for sub-woofer

and you need to manual deactivate by command :

amixer set 'Mono Mux' Mixer

To Automate it acpi events could not be used , but pulseaudio configs are to be used. :

In /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf , add the following at the bottom just before .include analog-output.conf.common

[Element Mono Mux]
enumeration = select
[Option Mono Mux:DAC1]
name = analog-output

and also in /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf , add the following at the bottom just before .include analog-output.conf.common

[Element Mono Mux]
enumeration = select
[Option Mono Mux:Mixer]
name = analog-output-headphones

After that either restart the pc or run pulseaudio -k && sudo alsa force-reload

Now check if it has worked . either by playing out a song or opening alsamixer and connecting and disconnecting the headphone .

It seems that adding options snd-hda-intel model=ref to alsa-base.conf doesn't work in Ubuntu 13.10 Saucy as pointed out in this askubuntu question. and i dont know if headphones jack sensing works if following the answer mentioned in that question or if there is chirping noise from audio , as i haven't yet installed a 13.10 saucy or lts-saucy HWE.

And also hda-jack-retask can be obtained in older versions using ppa:diwic/ppa

Hope it helped.

EDIT : Editing more confs . analog-output-speaker.conf , anolog-output-speaker-always.conf etc.. in the same manner was required.

1

This configuration worked for me.

Basically using HDAJackRetask (from the package alsa-tools-gui) using Internal Speaker (Back) for Pin 0x10 and from and a specific device Output (Sound configuration). The profile "Test Speaker" doesn't show the subwoofer, yet I tested it with https://www.youtube.com/watch?v=PC7WEQsiz08 and the vibration is noticeable and the depth of the music sound is very good.

All is summarized in this screenshot:

alltheconfiguration

  • I am not even sure if this still works. Certainly not in Fedora right now. – alfC Mar 21 '18 at 21:41
  • When I setup my Inspiron 7720 17R SE in Ubuntu 16.04 in 2014/2015 there were jacks to configure and stuff but I don't think the screen looked like that. I haven't used that laptop in a few months and before that I didn't use laptop speakers for a year as I had Sony TV with subwoofer sound device. Out of the box the subwoofer didn't work but I did make it work. I'll try to remember how it was all setup. – WinEunuuchs2Unix Mar 22 '18 at 2:21
  • Actually I may have setup the subwoofer under Ubuntu 14.04. – WinEunuuchs2Unix Mar 22 '18 at 2:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.