39

There are many questions about resolution issues on askubuntu but no question/solution seems to solve my issue.

I've a 12.04/precise host system and installed Ubuntu 12.04/precise as guest system as well. After installation I had the option of selecting 1024x768 (4:3) and 800x600 (4:3) as resolution in display settings. After installing guest additions the options 1280x960 (4:3) and 1440x1050 (4:3) was added to the list. Now 4 in total all having the 4:3 ratio.

I then activated full screen mode (host+f) and got the guest running in native 1920x1200 (16:10) for my screen. After deactivating full screen two more options had been added to the resolutions dropdown list, 1920x1200 (16:10) and 1600x1200 (4:3).

I want to run the guest in 1920x1080 (16:9) so I can easily record screencasts in "full-hd". Last time I had this problem the solution was to run "VBoxManage controlvm nameofyourVM setvideomodehint width height colordepth" command from the host but now I want to know if there is any easier way to solve this?

17 Answers 17

29
  1. Go to the File menu and activate Environment setting or, in more recent versions, Preferences.
  2. Select Display and change the setting for Maximum guest screen size to “hint” which allows you to set an arbitrary size for both width and height (e. g. 1920 and 1200).
  3. Reboot the virtual machine and enjoy it.
4
  • 2
    Which file menu are you talking about?
    – CHolmstedt
    Mar 10, 2015 at 17:42
  • 1
    @CHolmstedt The file menu of the Virtualbox Manager works.
    – Marcel
    May 13, 2016 at 19:07
  • 7
    Sadly this didn't work for me using an ubuntu 16.04 guest on Windows 7 and VirtualBox 4.3.12. Ubuntu screen can't be resized and won't go larger than 1024 x 768.
    – snark
    Sep 4, 2017 at 11:13
  • 1
    Unfortunately, this didn't work for me using Ubuntu 18.04 guest on Windows 10 and Oracle VM Virtual Box 6.1 Apr 14, 2021 at 11:25
13

Further modification to the answers from @sangsoo-kim and @wery-nguyen for more clarity and improved utility:

  • Start the VirtualBox application on your host
  • Select your Windows guest VM from the list of VMs
  • Goto File > Preferences on the VirtualBox app menu
  • Select Display from the list of preferences
  • Change Maximum Guest Screen Size pull down to None

Now start the VM and you'll be able to resize the host container window to any dimensions you want, and the VM will automatically adjust!

This does require that the matching version of VirtualBox Guest Additions is installed and running inside your VM. Check the status bar inside your Windows VM for a small VirtualBox icon (usually has a yellow star). If you have that icon in your Windows VM status bar it means the Guest Additions are installed. Confirm that the version number matches the VirtualBox App version running on your host (hover over that icon to see the Guest Additions version number and do a "Help > About" in the Virtual Box app to see that version number).

p.s. You can also do this while the Windows VM is running, if that doesn't work, restart the VM after making the change.


Edit Aug 22, 2018 -- you may also have to twiddle with the Adjust Windows Size and Auto-resize Guest Display items on the VirtualBox View app menu to get resize working correctly.

VirtualBox "View" menu

3
  • Auto-resize Guest Display worked for me without any change!
    – Reza Taba
    May 23, 2021 at 19:50
  • 1
    This solution worked for me on Ubuntu 20.04
    – HadidAli
    Jul 20, 2021 at 14:27
  • 1
    The following answer helped me to install the VirtualBox Guest Additions: askubuntu.com/a/22745/1463276
    – Tobi Obeck
    Oct 4, 2021 at 17:05
10

Just install Virtualbox Guests Additions but before be sure you have DKMS in terminal:

sudo apt-get install dkms

and update:

sudo apt-get update

sudo apt-get upgrade

after this install guests additons,restart pc and you got the right screen ratio.

2
  • 3
    I'm afraid that didn't help me. As I said in the first post Guest additions are already installed.
    – CHolmstedt
    Nov 6, 2012 at 6:37
  • In my case, I upgraded VirtualBox then upgraded Ubuntu, and somewhere along the line the guest additions seemed to stop working (the screen wasn't resizing). I reinstalled the guest addditions which upgraded them to the latest version, rebooted the guest VM, and everything started working again (could change the VM resolution).
    – jfritz42
    Nov 12, 2012 at 18:17
9

(8 years later) this worked for me

sudo cvt 1920 1080 60    
sudo xrandr --newmode "1920x1080_60.00" 173.00 1920 2048 2248 2576 1080 1083 1088 1120 -hsync +vsync
sudo xrandr --addmode Virtual1 1920x1080_60.00

then go to display settings and you should find it

source

3
  • 1
    I'm using windows 10 on host and ubuntu 20.10 on virtual box, those commands worked for me, after run those comments, the screen changed to 640x480, but I opened the display settings the 1920x1080 (16:9) was now available. Thanks Mar 28, 2021 at 14:08
  • 1
    Just used it with the latest Ubuntu and VirtualBox. So still works. Thanks a lot!
    – Shtefan
    May 24, 2021 at 0:12
  • The link shared is broken, consider to update it. Thank You. Nov 15, 2021 at 0:24
7

I faced the same problem with KDE neon as host and Ubuntu 20.04 a guest.

I changed the machine setting in the Virtual Box Manager, Display tab.

Instead of using VMSVGA (I do not know how this setting was set) I put VBoxSVGA. This worked for me.

2
  • So easy, and the only solution of all that actually worked! After switching to VMboxSVGA you'll find 1920x1080 in your display settings under ubuntu Sep 23, 2021 at 17:53
  • Careful to change the settings recommended by VirtualBox - it arises an invalid settings detected warning message Nov 24, 2021 at 19:43
7

This is based on the answer of @Sangsoo Kim which works well for me:

  1. Go to File > Preferences
  2. Go to Display
  3. Change Maximum Guest Screen Size to Hint
  4. Enter 1920 x 1200 as a width and height.
  5. Restart the virtual machine and voila! It just shows the right resolution.

Hope this help!

1
  • 1
    You mean if I set the resolution to 1920x1200 then after restart, I will get the right resolution, which is 1920x1080 as the OP asked for?
    – karatedog
    Mar 14, 2021 at 1:21
6

I tried a lot, but just changing the graphics settings/graphics controller in the host machine's options from VMSVGA to VBOXSVGA started the Ubuntu VirtualBox immediately in the right resolution for me, i.e. 1920x1080.

3
  • That is the correct answer. Nothing else is required. Funny thing that VirtualBox will alert you that "Invalid settings detected", but everything will work fine.
    – Shtefan
    Jul 21, 2021 at 23:17
  • Not fair to put the exactly same answer that was put 2 and half month ago.
    – Jean-Marc
    Oct 2, 2021 at 17:16
  • Careful to change the settings recommended by VirtualBox - it arises an invalid settings detected warning message Nov 24, 2021 at 19:43
1

I had the same issue, i installed fresh ubuntu, then updated all packages + dkms, then rebooted in fullscreen. Installed the Guest Additions while being in fullscreen mode, and rebooting in fullscreen...

This fixed it for me.

1

I know there has benn a long time since last activity in this thread but this helped me and is thanks to you. In my case the tools where already installed.

  1. install dkms
  2. enter full-screen mode
  3. uninstall the tools
  4. reboot
  5. install the tools again
1

Running linux 18 on VirtualBox 6.1, I tried several things here. This is what worked for me

Start the ubuntu virtual environment.

Terminal: sudo apt-get install virtualbox-guest-dkms virtualbox-guest-x11

Turn off ubuntu.

In the virtual box window: File -> Preferences -> Display -> Maximum Guest Screen Size: None

Start ubuntu.

In applications, open Displays -> Click Resolution (now I had to drag the window, because it couldn't display the various resolution options) -> Choose a different setting (long list to choose from) and press Apply.

1

TLDR: If you have 2 monitors, move the vm window to the second monitor, alter resolution in the vm, then move it back.

If you google this issue, there are a lot of threads with the same symptom, all with different solutions. It's clear that this is a symptom that can be caused by multiple root causes. I had multiple Linux Distros (Ubuntu 20.04, 21.04 and 21.10, Debian 10 and 11, and Manjaro) as vms that could not display 1080p resolution , but could display 4:3, 16:10 and lesser 16:9 resolutions. Both of my monitors are maximum 1920x1080, so that should be the obvious inherited resolution of the guest.

This problem occurred both in virtualbox and vmware player... I moved my vm to my second monitor, noticing that after doing so I was able to full screen the vm and set resolution to 1080p. I was then able to move the vm back to my primary monitor, retaining the 1080p resolution. For some reason, something about my primary monitor is preventing guests from including 1920x1080 in the list of available resolutions, despite it being a 1080p monitor.

Since it happens on both vmware and virtualbox, its probably not obvious that its a bug in the virtualization software. That being said, if the host can detect my resolution on first boot of my newly formatted pc, the guest should be able to as well, and the logic for that detection would seem to be at fault. For my particular use case, its probably very hard to reproduce and thus not been debugged. Interestingly Fedora 34 got it right the first time, it was able to identify my correct resolution without me having to manually set it...

0

I too had the same issue. I installed dkms and then installed the Linux headers as per @Daniel answer. Then rebooted Ubuntu while remaining in full screen mode and it switched straight to the correct 16:9 resolution.

0
  1. Install VirtualBox tools
    Check before this manual
    https://www.virtualbox.org/manual/ch04.html#idp49439248

  2. Reboot.
0

I had the same issue, but now it works. I had to install:

sudo apt-get install linux-headers-`uname -r`

The error was logged in: /var/log/vboxadd-install.log

2
  • @CHolmstedt So did it work?
    – Daniel
    Oct 26, 2013 at 7:01
  • @Daniel No, I'm afraid not. I have not found any solution that works for my problem yet.
    – CHolmstedt
    Oct 27, 2013 at 7:45
0

I have a working method. This will work for sure 100% . This method works in Oracle Virtual Box All you have to do is go to run command prompt as administrator Then type the following command- cd "C:\Program Files\Oracle\Virtualbox" After typing this command now you have to check what name have you given to your OS when creating a new Profile for OS in virtual box . for e.x. I want my MAC OS to full HD , i named my OS as MAC OS ,so the command will be- VBoxManage setextradata "MAC OS" VBoxInternal2/EfiGraphicsResolution 1920x1080 Only these two commands, just replace MAC OS with your OS name in virtualbox , just restart your virtual box and see the effect ;) thank me later.

0

I had to go to the display settings of ubuntu in the virtual machine and change the display resolution to 1920x1200. Worked fine in my case

-1

For me , I couldn't get the Linux Mint window to display crystal clear without having the scrollbars showing lost screen space. When I selected the resize in the top right (2 square boxes that resize windows) to get everything to fit, the fonts on the screen turned fuzzy.

The answer was to select View > Full Screen Mode from the top menu after I got the warning box on startup about the switch mode. This puts a small hidden VBox menu at the top of the screen which is perfect. You can see "Full Screen Mode" on the picture of the menu in one of the posts above.

1
  • 1
    Mint is off-topic here and although applicable such triviality was already mentioned in many other answers. Jan 30 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.